COM-7

IrCOMM2k
2006-03-07
2013-04-08
  • I tried to use this driver on laptop with integrated IRda and winXP to connect glucometer ACCU-CHEK,
    but after installation I get virtual port with number 7.
    software I use, serve only COM-1 to COM-3.
    Does anybody know how to change this settings for "lower" com port ?
    Roman

     
    • You should disable the COM-1 in the peripheric manager Windows and then re-install IrCOMM2k.

       
    • jhçoi

       
    • read the manual....

      http://www.ircomm2k.de/English/troubleshooting.html#HardwareOK

      >
      In order to manually specify the port, start regedt32.exe (e.g. via "Run" in the Start Menu). Below Registry-entries have to be adjusted, some require additional access rights:

      HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\SERIALCOMM\Device\Ircomm0
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Ports
      (should the desired COM port number be missing altogether, please add it)
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\IRCOMM2K\0000\FriendlyName
      (Cosmetic, so that the device manager displays a meaningful name)
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\IRCOMM2K\0000\Device Parameters\PortName
      When above changes were made, the virtual COM port has to be disabled, then re-enabled in the Device Manager (or, alternatively, restart the entire system).