Dear Sirs,
   I have been using IPSec 0.6.5 rpm coming with Fedora Core6 to build a VPN tunnel between 2 machines, automatic key exchange with racoon was configured, everything was OK for 2 years.
  I updated one of the machines to Fedora 14 coming with IPSec 0.7.3 and the tunnel broke. Tried to get it running without racoon by configuring manual keys (the same manual key exchange configuration is working between FC6 FC6), still no success. Ping request is passing through the tunnel both ways with encryption, no response from the recepient as if he is deaf.
   I read that RFC 1825-1829 conventions have been updated for ESP to RFC2401-2414, no field is present in the packet with info about the current version used by the sender. Could it be that there is incompatibility between the different versions of IPSec, namely 0.6.5 and 0.7.3? Is the newest version 0.8 of IPSec compatible with 0.7.3 and is it possible to use different IPSec versions at both ends of a tunnel?
My search for info on this subject gave no result.
Waiting for Your comment. Best regards!
Andrei
Plovdiv, Bulgaria