#64 useless -lselinux option

closed
nobody
Compilation (8)
5
2009-01-16
2007-06-19
Vincent G.
No

Version is : ipsec-tools-0.7-rc1

I'm using a debian.

"configure" is ok.
So I run "make".

Make stops on:
---------
gcc -I../../src/libipsec -include ../../src/include-glibc/glibc-bugs.h -I../../src/include-glibc -I../../src/include-glibc -g -O2 -Wall -Werror -Wno-unused -o setkey setkey.o parse.o token.o ../libipsec/.libs/libipsec.a -lfl -lutil -lcrypto -lresolv -lselinux
/usr/bin/ld: cannot find -lselinux
---------

libselinux is only available on Suse.

Running the following command is a workaround:
---------
enable_security_context=no ./configure
make
---------

Discussion

  • Timo Teras
    Timo Teras
    2009-01-16

    • status: open --> closed
     
  • Timo Teras
    Timo Teras
    2009-01-16

    Closing all sourceforge.net bugs. If this issue has not been cared for please submit a new bug report to https://trac.ipsec-tools.net/ issue tracker. Thank you.