Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

How to install innotop

Help
pk6666
2007-11-03
2013-04-19
  • pk6666
    pk6666
    2007-11-03

    Hi, I am using this tool or perl by itself for first time.
    I printed the perl version , then I proceeded with the make,
    If anybody can document what are the pre-requisites to run this utility , much appreciated.
    Have mysql installed from tar ball in /opt/mysql/5.0.46
    Thx in advance,

    When I try to install innotop I get the following warnings,
    /home/mysql/tmp/innotop-1.4.3>perl Makefile.PL
    Warning: prerequisite DBD::mysql 1 not found.
    Warning: prerequisite Term::ReadKey 2.1 not found.
    Writing Makefile for innotop
    ---------------------------------------------------------------------
    q1derdb{}:/home/mysql/tmp/innotop-1.4.3>type perl
    perl is a tracked alias for /usr/bin/perl
    q1db{}:/home/mysql/tmp/innotop-1.4.3>perl -version

    This is perl, v5.8.8 built for x86_64-linux-thread-multi

    ------------------------------------------------------------------------
    :/home/mysql/tmp/innotop-1.4.3>make install
    cp InnoDBParser.pm blib/lib/InnoDBParser.pm
    cp innotop blib/script/innotop
    /usr/bin/perl "-MExtUtils::MY" -e "MY->fixin(shift)" blib/script/innotop
    Manifying blib/man1/innotop.1
    Manifying blib/man3/InnoDBParser.3pm
    Warning: You do not have permissions to install into /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi at /usr/lib/perl5/5.8.8/ExtUtils/Install.pm line 114.
    Installing /usr/lib/perl5/site_perl/5.8.8/InnoDBParser.pm
    Installing /usr/share/man/man1/innotop.1
    Installing /usr/share/man/man3/InnoDBParser.3pm
    Installing /usr/bin/innotop
    mkdir /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/auto/innotop: Permission denied at /usr/lib/perl5/5.8.8/ExtUtils/Install.pm line 207
    make: *** [pure_site_install] Error 13

     
    • Baron Schwartz
      Baron Schwartz
      2007-11-04

      The important bits are

      Warning: prerequisite DBD::mysql 1 not found.
      Warning: prerequisite Term::ReadKey 2.1 not found.

      You will need to install these.  I strongly recommend installing them through your operating system's package repositories instead of through CPAN, if possible.

       
    • pk6666
      pk6666
      2007-11-08

      Thanks and it worked