Thanks for the update - anyone know when/if the extensions will be fixed (or how to fix them)?
on OS X snow leopard the items under extensions still give the python error
"The fantastic lxml wrapper for libxml2 is required by inkex.py and therefore this extension. Please download and install the latest version from http://cheeseshop.python.org/pypi/lxml/, or install it through your package manager by a command like: sudo apt-get install python-lxml"

I know it's known of, just wondering if a solution was n the horizon.
I did try installing python but guess I don't know what I'm doing as it didn't work LOL

Thanks

Gaz(UK)

2009/11/24 Joshua A. Andler <scislac@gmail.com>
Greeting to the community,