install in Linux without internernet

2007-06-07
2012-10-08
  • I've been trying to install Inkscape in ubuntu 5.04. I have Fiesty on the way, but this will still be a good learning experience, so I can do it again on my laptop. I've been trying to do an autopackage install. To do this, one needs a couple extra files, the GUI, and a bz2 file. I have all these files in the same directory, but every time I go to install the inkscape package, it keeps asking for the bz2 file. I've done everything I could think of. I've extracted, made executable, and intstalled the bz2 file in the parent file where the Inkscape package is, and I've copy>pasted the Inkscape package down into some child folders.(Along with the execute, install routine).
    I've tried apt-get install, and sudo install, no matter what I do, I still get the box requesting the bz2 file. The file's right there, same directory. I thought there was a long shot that since I was using a MS windows machine to download the bz2, it changed the file extension to .tar.tar, instead of tar.bz2. After moving it to the Linux hard drive, it shows as the tar.tar extension. Maybe no big deal, like it's still a tarball. Whatever the filetype, it might as well not be there at all, since the Inkscape doesn't know it's there.

    Thanks for any help.

     
    • Thanks, I'll look into those things.

       
    • Probably I can't be of much help, as I used the online Fedora repositories myself. They work like a charm. Maybe trying to find an internet connection is the easiest way...

      Probably you have already read http://autopackage.org/docs/howto-install/index.html? Did you try running in a terminal to see if there are any additional error messages?

      Maybe it does find the .bz2 file but it cannot be read for some reason (and therefore asks for another bz2 file)? Something could have went wrong when transferring the file from Windows to Linux.

      You could also download the source code from SVN and try to compile Inkscape yourself, but there will be other pitfalls.