Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Inkscape won't run, X11 issue

2005-11-23
2012-10-08
  • So I downloaded the latest version, opened the .dmg, and dragged Inkscape to the apps folder. When I launched inkscape I get a little window saying that I need to get X11.

    Alright, no problem, I clicked a button on the window that lead me to Apple's website where I downloaded X11. When I tried to install that, it told me that I already had a newer version installed.

    So, apparently, I have the latest version of X11 but inkscape still refuses to run. and I'm puzzled.

     
    • I have the same problem --- and installed X11 from install disks on to new 24inch Core2Duo Intel iMac and it still giving me the message aboutit. Downloaded what I thought was update X11 and it says not for this machine.

      Now what?
      :-)

       
    • So am I. So we are two. Under MacOS10.3.8 Inskape won´t open: CrashLog reports: can´t open library:../../libstd++6.dylib (no such file or directory, errno=2)
      S what to do?
      Please help

       
    • Same here.

      Also latest version of Inkscape, OSX 10.4.4.
      And downloaded version of X11 from the mac site. And same error about a newer version being allready installed.

       
    • Open X11 first time from terminal, then command-option-A to get out of Kiosk mode. Go to preferences and disable kiosk mode (you don't need it). Then control click on your dock icon for X11 and clip keep in dock. Should work from there. I've been using Inkscape for hundreds of hours in X11 without crash or freeze. Good luck

       
    • I am experiencing the same issues and have been around and around trying to figure this out! I AM new to this side of OSX but have learned a lot to <probably> be dangerous in a short time.
      I have had the same error message about X11 being newer on my system.
      Just to be certain: is X11 Starter.app what I'm supposed to open? I get the window but command-option-A doesn't move me out of the kiosk mode -- in fact I can change the environment (default/Apple/twm, select/unselect Fullscreen and Terminal, and click Start MANY times, yet I cannot budge.
      Please help this newbie out! Thanks so much, sharon

       
    • Hey -- I got it!
      To answer my own question: X11Starter.app is NOT what I needed. I found X11 tucked away on the Tiger installation disc (had to scroll down and click on Optional Install then Customize -> Applications -> X11).
      Now Inkscape is running on both of my machines running 10.4.5 just fine! sharon 'gain