Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Installation on OSX

2005-07-27
2012-10-08
  • I downloaded the 0.42-0.dmg file, opened it, dragged the inkscape app into the applications folder, clicked on the inkscape add and the Inkscape app seemed to start opening (title bar changed briefly) then that ended and X11 opened. That's the end of the sequence. If I try to re-open the inkscape app once X11 is open, no change. quit X11, retry, same thing.

    What do I have misconfigured?

     
    • That happened to me as well.. I was stumped when i said I had a newer version installed.. yet nothing..
      I searched and searched till I found this site.

      http://cjmart.in/2006/12/01/install-x11-on-tiger-without-the-tiger-install-dvd/

      Installed - rebooted - worked perfect
      ( minus the fact I am "not allowed" to install some python stuff to get the blur to work )
      (boss says "do not use your work MAC for something tother then work!" go figure!)

       
    • Oh also.. use 0.45 instead of 0.42 for 10.4.8+

       
    • Same here!

       
    • This was reported on the mailing list; I don't know if it'll fix the reported issue, but may be worth trying:

      >>ok, so it turns out that none of these users ae doing anything wrong.
      >>There is just a common problem on OS X 10.4.x where the X11 installer
      >>doesn't properly generate the font cache. So when any X11 app using
      >>fontconfig starts it crashes, not finding any fonts.
      >>
      >>The fix is to run the following command:
      >> sudo fc-cache
      >>
      >>Those two new OSX crash bugs are both this problem.

       
      • That fixed it. Thanks a ton.

        Possible helpful clarification:

        sudo fc-cache

        must be run in an X11 terminal window, not the "terminal" application.

         
    • The X11 interface opens in the kiosk mode first time (grey screen), command-option-A and go to prefernces to disable the kiosk mode. You should have easy access to Inkscape as well as xterm and terminal

       
    • I tried to install it on OSX 10.4.8 placed it in my applications file and was told I needed the X11 so I went and downloaded it but it wouldnt let me install it because it said I had a newer version on my computer......stumped