Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Format DV25 in Primary Buffer

Developers
2012-07-18
2013-04-25
  • Marc Struminki
    Marc Struminki
    2012-07-18

    Hello Philip, hello Devs.
    is it Possible to add the Format DV25 to the Primary buffer?
    Currently we use the secondary buffer for MPEG video. We need for a project DV25 and MPEG simultaneously.

     
  • Hello *,

    I second that, as it could be very useful for us, too.
    It would be really great if you could add both DV25 & MPEG to primary buffer in order to have total freedom in picking buffers.

    We have a project where I only use h264/aac/mp4 with BITC.
    For this we have to configure a primary buffer as either UYVY, YUV422 or DV50 and secondary buffer as MPEG .
    Sure it's working fine, but why allocating RAM for a buffer that is never used? 

    Cheers
    Michael

     
  • John Fletcher
    John Fletcher
    2012-07-19

    I will have a look at this.  It may not be too hard.

     
  • John Fletcher
    John Fletcher
    2012-07-30

    I've updated dvs_sdi to allow other formats for primary buffer.

     
  • JReykdal
    JReykdal
    2012-07-30

    This is pretty cool.

     
  • I've made made a patch for bmd_sdi.cpp with the same 'primary buffer' changes.
    http://pastebin.com/0Jg2bnZN

    It compiled on a Suse 12.1 VM.
    But I don't know if it actually works as don't have Decklink hardware to test here.

     
  • Now I've tested it with Decklink hardware.
    Recording with either DV25 or MPEG as primary Buffer worked fine.
    Only setting "None" as primary Buffer (and MPEG as secondery buffer) results in recorder error & exit.

     
  • John Fletcher
    John Fletcher
    2012-07-31

    Thanks for the patch.  I tested too and will update cvs shortly.
    Don't think I intended format "None" to be supported for primary buffer although I can see in HD case why you might want that.

     
  • Thank you. :-)

    I don't really need "None" for the primary buffer. I just tested it as it now is an option.

     
  • John Fletcher
    John Fletcher
    2012-08-02

    Just uploaded some fixes for primary format "None"