Failed to create DVS driver

Help
lilouk
2012-06-09
2013-04-25
  • lilouk
    lilouk
    2012-06-09

    Hi,
    When I tired to create dvs driver with ./driver_create I got these messages:

    /home/bsd/Install/sdk4.0.1.17/development/src_lucy/driver//linux.c:129:3: error: #error Kernel version is not supported by dvsdriver!
    make: ***  Error 1
    make: ***  Error 2
    make: ***  Error 2
    make: ***  Error 2
    make: Leaving directory `/usr/src/linux-3.1.10-1.9-obj/x86_64/default'
    make: ***  Error 2
    make: Leaving directory `/home/bsd/Install/sdk4.0.1.17/development/src_lucy/driver'
    make: Entering directory `/home/bsd/Install/sdk4.0.1.17/development/src_v4r3/driver'
    make -C /lib/modules/`uname -r`/build M=`pwd`
    make: Entering directory `/usr/src/linux-3.1.10-1.9-obj/x86_64/default'
      LD      /home/bsd/Install/sdk4.0.1.17/development/src_v4r3/driver/built-in.o
      CC   /home/bsd/Install/sdk4.0.1.17/development/src_v4r3/driver//linux.o
    /home/bsd/Install/sdk4.0.1.17/development/src_v4r3/driver//linux.c:135:3: error: #error Kernel version is not supported by dvsdriver!
    make: ***  Error 1
    make: ***  Error 2
    make: ***  Error 2
    make: ***  Error 2
    make: Leaving directory `/usr/src/linux-3.1.10-1.9-obj/x86_64/default'
    make: ***  Error 2
    make: Leaving directory `/home/bsd/Install/sdk4.0.1.17/development/src_v4r3/driver'
    make: Entering directory `/home/bsd/Install/sdk4.0.1.17/development/src_lucy/driver'
    make -C /lib/modules/`uname -r`/build M=`pwd`
    make: Entering directory `/usr/src/linux-3.1.10-1.9-obj/x86_64/default'
      CC   /home/bsd/Install/sdk4.0.1.17/development/src_lucy/driver//linux.o
    /home/bsd/Install/sdk4.0.1.17/development/src_lucy/driver//linux.c:129:3: error: #error Kernel version is not supported by dvsdriver!
    make: ***  Error 1
    make: ***  Error 2
    make: ***  Error 2
    make: ***  Error 2
    make: Leaving directory `/usr/src/linux-3.1.10-1.9-obj/x86_64/default'
    make: ***  Error 2
    make: Leaving directory `/home/bsd/Install/sdk4.0.1.17/development/src_lucy/driver'
    make: Entering directory `/home/bsd/Install/sdk4.0.1.17/development/src_v4r3/driver'
    make -C /lib/modules/`uname -r`/build M=`pwd`
    make: Entering directory `/usr/src/linux-3.1.10-1.9-obj/x86_64/default'
      CC   /home/bsd/Install/sdk4.0.1.17/development/src_v4r3/driver//linux.o
    /home/bsd/Install/sdk4.0.1.17/development/src_v4r3/driver//linux.c:135:3: error: #error Kernel version is not supported by dvsdriver!
    make: ***  Error 1
    make: ***  Error 2
    make: ***  Error 2
    make: ***  Error 2
    make: Leaving directory `/usr/src/linux-3.1.10-1.9-obj/x86_64/default'
    make: ***  Error 2
    make: Leaving directory `/home/bsd/Install/sdk4.0.1.17/development/src_v4r3/driver'
    cp: cannot stat `../../development/src_lucy/driver/dvsdriver_lucy.ko': No such file or directory
    cp: cannot stat `../../development/src_v4r3/driver/dvsdriver_v4r3.ko': No such file or directory
    cp: cannot stat `../../development/src_lucy/driver/dvsdebug_lucy.ko': No such file or directory
    cp: cannot stat `../../development/src_v4r3/driver/dvsdebug_v4r3.ko': No such file or directory

    I have sdk4.0.1.17
    Opensuse 12.1 x64
    3.1.10-1.9-default kernel

    Thank you for your help

     
  • John Fletcher
    John Fletcher
    2012-06-11

    Try a more recent SDK such as 4.1.0.4

     
  • lilouk
    lilouk
    2012-06-11

    Hi John,
    I have to patch src_v4r3/driver/linux.c and src_lucy/driver/linux.c  ?
    Thank you

     
  • John Fletcher
    John Fletcher
    2012-06-11

    Not in more recent SDKs

     
  • lilouk
    lilouk
    2012-06-11

    I'll try 4.1.0.4sdk .
    Thank you John

     
  • lilouk
    lilouk
    2012-06-12

    Work !
    Thank you

     
  • lilouk
    lilouk
    2012-12-07

    Hi,
    I got the same issue with my new installation:
    Opensuse 12.1 x64
    kernel 3.1.10-1.16-default
    #error Kernel version is not supported by dvsdriver!
    Thx

     
  • lilouk
    lilouk
    2012-12-07

    Sorry about that :-(
    It's working now