Problem start multicast

stefano
2012-07-26
2013-04-25
  • stefano
    stefano
    2012-07-26

    I put in ingex.conf MULTICAST = 1.
    StartIngex launch and open a terminal and just enough.
    Why?

     
  • John Fletcher
    John Fletcher
    2012-07-27

    Are you saying it opens a terminal but nothing happens?
    Do you see anything in the terminal?

     
  • stefano
    stefano
    2012-07-27

    Yes, it's open a teminal but nothing,
    Newver messages, only prompt

     
  • stefano
    stefano
    2012-07-30

    Yes,  it's open a teminal but nothing, on prompt on Home directory.

     
  • Matthew Marks
    Matthew Marks
    2012-07-30

    I've fixed a bug in startIngex_kde4.sh - I'll see if there are any knock-ons and a fix should be uploaded soon.

     
  • stefano
    stefano
    2012-08-01

    Yes, I also solved the problem lies for the multicast startIngex_kde4.sh:

    at line 291

    # ** multicasting **
    if [ $MULTICAST -ge 1 ] ; then
      SetupTab "Multicast"
    [b]  WriteCommand "cd $capture_path"[/b]
      # Prepare options. If mpeg transport stream, set -t option and bitrate
      if [ $MULTICAST_MPEG_TS -ge 1 ] ; then
        OPTIONS="-t -b ${MULTICAST_MPEG_BIT_RATE}"
      fi
      OPTIONS="${OPTIONS} -s ${MULTICAST_SIZE}"
      PORT=$MULTICAST_FIRST_PORT
      [b]CHAN=0[/b]
      while [ "$CHAN" -lt "$CAPTURE_CHANNELS" ] ; do
        echo "Starting multicast channel ${CHAN}"
        WriteCommand "./nexus_multicast -c ${CHAN}  ${OPTIONS} ${MULTICAST_ADDR}:${PORT} &"
        let CHAN=$CHAN+1
        let PORT=$PORT+1
      done
    fi
    

    I also removed the -q option, otherwise the multicast would not start.
    Why?

     
  • John Fletcher
    John Fletcher
    2012-08-02

    I've updated the file.
    Don't know about -q, seems to work for me.