Question for Waning AUDIO AESEBU

stefano
2012-09-07
2013-04-25
  • stefano
    stefano
    2012-09-07

    Hi,
    on capture I have this Warnig:

    Warning chan ho audio present SV_ERROR_INPUT_AUUDIO_NOAESEBU.
    There is no AES/EBU Audio Inpute Detected.

    But I have Audio.
    Why this warning?

     
  • John Fletcher
    John Fletcher
    2012-09-10

    Are you using AES input for audio?  If not, then you shouldn't get this error with latest source code.

    If you are using AES audio, note that the error is on input 1, i.e. the second input, are you sure you have audio there?  If you only get the message occasionally, it could be to do with AES audio not being locked to video.

     
  • stefano
    stefano
    2012-09-12

    We solved.
    We use AES, with 8 audio and routing a4: 4. thanks

     
  • stefano
    stefano
    2012-09-13

    Hello, we still have a problem on the audio.
    On the PC we have only one capture card centaurus in hd.
    The audio is AES / EBU on channel 1/2 and 5/6
    the option LTC is activated.
    We have a configuration like this:
    cam1: v1, v1a1, v1a2, v1a3, v1a4
    cam2: v2, v2a5, v2a6, v2a7, v2a8
    With ingex gui see:
    - Cam 1 with the first 2 channel audio  sound ok and the other 2 channel without audio. modulation on audio channels 1 and 2 it's OK
    - Cam 2 with the first 2 channel audio  sound ok and the other 2 channel without audio. modulation on audio channels 1 and 2 it's OK
    The capture him we start with -a8 and -AES4: 4.
    The audio on the first cam is correct.
    The audio on second cam is not the correct audio.
    the files will be create but no sound in
    How do we get the first 4 channels of AES / EUB on the first cam while the other 4 on the second cam?

    If we put the -aes8 we have warning on capture:
    on the channel  no audio present -sv_error_imput_audio_aiv. there is no aiv audio signal in video imput detected
    can you tell us the rigth config.?

    thx

     
  • John Fletcher
    John Fletcher
    2012-09-13

    The option -aes4:4 should give what you want.
    You can omit -a8
    What audio do you see if you use play_cam2.sh from ingex/studio/scripts/ ?

     
  • stefano
    stefano
    2012-09-13

    Hi
    play_cam2.sh from ingex/studio/scripts/
    do this message

    ingex@ingexc:~/ap-workspace/ingex/studio/scripts> ./play_cam2.sh 
    Info: Version: version 0.91, build: Sep 10 2012 21:44:06
    Info: Waiting for shared memory to appear...
    Info: Connected to shared memory
    Info: X11 display adaptor 0, port 505, format 0x59565955 (UYVY) packed
    Info: X11 display adaptor 0, port 505, format 0x30323449 (I420) planar
    Info: Auto detected X11 XV output available
    Cannot connect to server socket err = No such file or directory
    Cannot connect to server socket
    jack server is not running or cannot be started
    Info: X11 display adaptor 0, port 505, format 0x59565955 (UYVY) packed
    Info: Failed to pass through connect stream 3 (sound, pcm)
    Info: Failed to pass through connect stream 4 (sound, pcm)
    Warning: Source media has unknown length
    Unlocked
    Playing
    Started
    Speed 1x
    Start of source reached: [S-LTC] 16:57:19:15 [S-VITC] 00:00:00:00 [S-DLTC] 00:00:00:00 [S-DVITC] 00:00:00:00 [X] 16:58:29:08 
    X Error of failed request:  BadAlloc (insufficient resources for operation)
      Major opcode of failed request:  132 (XVideo)
      Minor opcode of failed request:  19 ()
      Serial number of failed request:  36
      Current serial number in output stream:  37
    

    ingex@ingexc:~/ap-workspace/ingex/studio/scripts>

    thx

     
  • stefano
    stefano
    2012-09-13

    Hi
    in the same pc with Atonix LT we have this error:

    13 19:31:36.409333 chan 0: Video signal OK
    13 19:31:36.432248 Warning: chan[0] no audio present - SV_ERROR_INPUT_AUDIO_NOAIV. There is no AIV audio signal in video input detected.
    13 19:31:36.472542 Warning: chan[0] no audio present - SV_ERROR_INPUT_AUDIO_NOAIV. There is no AIV audio signal in video input detected.
    13 19:31:36.512589 Warning: chan[0] no audio present - SV_ERROR_INPUT_AUDIO_NOAIV. There is no AIV audio signal in video input detected.
    13 19:31:36.514823 chan 0: sv_fifo_getbuffer(): (190) SV_ERROR_FIFO_STOPPED. This command cannot be done while the FIFO is stopped.
    13 19:31:36.514842 chan 0: failed to capture video: (190) SV_ERROR_FIFO_STOPPED. This command cannot be done while the FIFO is stopped.
    13 19:31:36.957007 chan 0: wait_for_good_signal() returning
    13 19:31:36.957035 chan 0: Setting SV_FIFO_FLAG_FLUSH
    13 19:31:37.115079 chan 0: Timestamp differs from expected by 117 ms
    13 19:31:37.115102 chan 0: Need to recover 3 frames
    13 19:31:37.115108 chan 0: Recovered.  lastframe=8195 ltc=1755677
    13 19:31:37.115122 chan 0: Video signal OK
    13 19:31:39.754579 chan 0: sv_fifo_getbuffer(): (190) SV_ERROR_FIFO_STOPPED. This command cannot be done while the FIFO is stopped.
    13 19:31:39.754596 chan 0: failed to capture video: (190) SV_ERROR_FIFO_STOPPED. This command cannot be done while the FIFO is stopped.
    13 19:31:40.199240 chan 0: wait_for_good_signal() returning
    13 19:31:40.199296 chan 0: Setting SV_FIFO_FLAG_FLUSH
    13 19:31:40.354815 chan 0: Timestamp differs from expected by 79 ms
    13 19:31:40.354851 chan 0: Need to recover 2 frames
    13 19:31:40.354857 chan 0: Recovered.  lastframe=8276 ltc=1755758
    13 19:31:40.354871 chan 0: Video signal OK
    13 19:31:40.392248 Warning: chan[0] no audio present - SV_ERROR_INPUT_AUDIO_NOAIV. There is no AIV audio signal in video input detected.
    13 19:31:40.431992 Warning: chan[0] no audio present - SV_ERROR_INPUT_AUDIO_NOAIV. There is no AIV audio signal in video input detected.
    13 19:31:40.471903 Warning: chan[0] no audio present - SV_ERROR_INPUT_AUDIO_NOAIV. There is no AIV audio signal in video input detected.
    13 19:31:40.512213 Warning: chan[0] no audio present - SV_ERROR_INPUT_AUDIO_NOAIV. There is no AIV audio signal in video input detected.
    13 19:31:40.551918 Warning: chan[0] no audio present - SV_ERROR_INPUT_AUDIO_NOAIV. There is no AIV audio signal in video input detected.
    13 19:31:40.594755 Warning: chan[0] no audio present - SV_ERROR_INPUT_AUDIO_NOAIV. There is no AIV audio signal in video input detected.
    13 19:31:40.632295 Warning: chan[0] no audio present - SV_ERROR_INPUT_AUDIO_NOAIV. There is no AIV audio signal in video input detected.
    13 19:31:40.673735 Warning: chan[0] no audio present - SV_ERROR_INPUT_AUDIO_NOAIV. There is no AIV audio signal in video input detected.
    13 19:31:40.712551 Warning: chan[0] no audio present - SV_ERROR_INPUT_AUDIO_NOAIV. There is no AIV audio signal in video input detected.
    13 19:31:40.754177 Warning: chan[0] no audio present - SV_ERROR_INPUT_AUDIO_NOAIV. There is no AIV audio signal in video input detected.
    13 19:31:40.791905 Warning: chan[0] no audio present - SV_ERROR_INPUT_AUDIO_NOAIV. There is no AIV audio signal in video input detected.
    13 19:31:40.831863 Warning: chan[0] no audio present - SV_ERROR_INPUT_AUDIO_NOAIV. There is no AIV audio signal in video input detected.
    13 19:31:40.872114 Warning: chan[0] no audio present - SV_ERROR_INPUT_AUDIO_NOAIV. There is no AIV audio signal in video input detected.
    13 19:31:40.912290 Warning: chan[0] no audio present - SV_ERROR_INPUT_AUDIO_NOAIV. There is no AIV audio signal in video input detected.
    13 19:31:42.634589 chan 0: sv_fifo_getbuffer(): (190) SV_ERROR_FIFO_STOPPED. This command cannot be done while the FIFO is stopped.
    13 19:31:42.634614 chan 0: failed to capture video: (190) SV_ERROR_FIFO_STOPPED. This command cannot be done while the FIFO is stopped.
    13 19:31:43.080997 chan 0: wait_for_good_signal() returning
    13 19:31:43.081028 chan 0: Setting SV_FIFO_FLAG_FLUSH
    13 19:31:43.249813 chan 0: Timestamp differs from expected by 77 ms
    13 19:31:43.249826 chan 0: Need to recover 2 frames
    13 19:31:43.249828 chan 0: Recovered.  lastframe=8348 ltc=1755830
    13 19:31:43.249835 chan 0: Video signal OK
    13 19:31:43.272189 Warning: chan[0] no audio present - SV_ERROR_INPUT_AUDIO_NOAIV. There is no AIV audio signal in video input detected.
    

    the fifo error start every time we press the E to E button on ingexgui window
    the problem with audio was just a test.
    other question:
    how disable audio on video channel for record just video?

    thanks