ILisp on Windows 2000

  • David E. Young
    David E. Young

    Ok. ILisp 5.11 on Windows 2000 with Allegro 6.1. What do I do to get pathnames with spaces accepted by ILisp. For example, "D:/Program Files/acl61/alisp", when handed to ALLEGRO, fails; the debugger trace looks like:

    start-process("allegro" #<buffer *allegro*> "d:/Program" "Files/acl61/alisp")
      apply(start-process "allegro" #<buffer *allegro*> "d:/Program" "Files/acl61/alisp")

    Notice how "Program" and "Files" are separated. I've tried various incantations with no luck.

    Thanks for the help.

    • Hi

      I forwarded the email to the ilisp-devel mailing list.

      Have you tried the standard trick

          "D:/Program\ Files/acl61/alisp"

      Marco Antoniotti

      • David E. Young
        David E. Young

        Yes, I tried that. The result is that "Program Files" is concatenated as "ProgramFiles" and a new error occurs.

        BTW, ACL's ELI parses the pathname correctly, so fundamentally it seems ok to do this.

        • William Deakin
          William Deakin

          I have seen a whole gamut of problems with xemacs, ilisp and clisp, lispworks under windows. This is because of the way that \ and /'s are passed to the lisp process. I can mail it to you -- I also posted it on c.l.l -- but hesitate to include it in the main distribution code because I *think* it migth breaks some stuff for unix versions of xemacs.

          Mail me at my source forge account if you want this patch mailing. (I need to attach it and this web thingie doesn't appear to let me do that!).


    • Ok.  It must be something in the guts.
      I assume that the string is the one you use
      to tell ILISP where ACL is.

      Isn't it?


      • David E. Young
        David E. Young

        Yes; this code fragment will illustrate:

        (defvar *acl-home* "d:/Program Files/acl61/")


        (setf allegro-program
              (concatenate 'string *acl-home* "alisp"))