running multiple versions on the same server

Help
DGSL
2009-09-21
2012-10-06
  • DGSL
    DGSL
    2009-09-21

    As I am getting some errors running svn version on Ubuntu-VirtualBox, I have
    gone back to version 0.9.7, which seems to work properly but has not zoomify
    support

    I wonder if it is possible to keep old versions running on the same server,
    like this:

    /var/www/fcgi-bin/iipsrv.0.9.7.fcgi

    /var/www/fcgi-bin/iipsrv.0.9.8.fcgi

    ... and so on, in a way that I can use any of them depending on the URL I load

    In case of being possible, I suppose I should change something on apache.conf,
    but not sure. Probably I should reproduce these lines for each of my fcgi
    binaries and also create different log files?:

    FastCgiServer /var/www/fcgi-bin/iipsrv.fcgi \

    -initial-env LOGFILE=/tmp/iipsrv.log \

    -initial-env VERBOSITY=2 \

    -initial-env JPEG_QUALITY=50 \

    -initial-env MAX_IMAGE_CACHE_SIZE=10 \

    -initial-env MAX_CVT=3000

    would this be enough?

     
  • Ruven
    Ruven
    2009-09-22

    Yes, you can have as many versions as you like running in parallel.

     


Anonymous


Cancel   Add attachments