iipimage server to ubuntu 12.04 (64 b)

Help
aragorn
2012-06-27
2012-10-06
  • aragorn
    aragorn
    2012-06-27

    Good morning.

    I have installed the iipimage-server_0.9.9-j2k-0ubuntu12.04_amd64.deb package
    as you have descibed in http://iipimage.sourceforge.net/2012/05/new-debian-
    and-ubuntu-packages-released/,
    but I don\\'t manage to do work it.

    When my apache2 service starts, I access to http://locahost/cgi-
    bin/iipsrv.fcgi
    and it works correctly.
    But after try to view the PalaisDuLouvre.tif image, my server give me the next
    response: \\"No response from server /fcgi-bin/iipsrv.fcgi\\" and after this
    if I try to access to http://locahost/cgi-bin/iipsrv.fcgi my server continues giving me the response: \\"No
    response from server /fcgi-bin/iipsrv.fcgi\\"

    Can you help me?

    Thank you in advance.

    aragorniip

     
  • Ruven
    Ruven
    2012-06-28

    You'll need to provide some more details. For example, what does it say in the
    iipsrv log file?

     
  • aragorn
    aragorn
    2012-06-29

    Thanks you for your attention.

    Here I copy the log file after access to:

    1.- http://localhost/cgi-bin/iipsrv.fcgi
    2.-
    http://localhost/iipimage/index.html

    <----------------------------------->
    Fri Jun 29 11:47:50 2012

    IIPImage Server. Version 0.9.9
    Ruven Pillay ruven@users.sourceforge.net

    Verbosity level set to 6
    Running in FCGI mode

    Setting maximum image cache size to 10MB
    Setting filesystem prefix to ''
    Setting default JPEG quality to 90
    Setting maximum CVT size to 5000
    Setting 3D file sequence name pattern to 'pyr'
    Setting up JPEG2000 support via Kakadu SDK
    Memcached support enabled. Connected to servers: 'localhost' with timeout
    86400

    Initialisation Complete.
    <----------------------------------->

    CVT maximum viewport size set to 5000
    QUERY_STRING not set

    Total Request Time: 156 microseconds
    image closed and deleted
    Server count is 1

    CVT maximum viewport size set to 5000
    Full Request is FIF=/imagenes/PalaisDuLouvre.tif&obj=IIP,1.0&obj=Max-size&obj
    =Tile-size&obj=Resolution-number
    : Command / Argument is FIF : /imagenes/PalaisDuLouvre.tif
    FIF handler reached
    FIF :: URL decoding/filtering: /imagenes/PalaisDuLouvre.tif =>
    /imagenes/PalaisDuLouvre.tif
    FIF :: Image cache initialisation
    FIF :: TIFF image requested
    FIF :: Created image
    FIF :: Image dimensions are 4000 x 828
    FIF :: Image timestamp: Tue, 26 Jun 2012 15:20:05 GMT
    FIF :: Total command time 546 microseconds
    : Command / Argument is obj : IIP,1.0
    OBJ :: iip,1.0 to be handled
    OBJ :: Total command time 3 microseconds
    : Command / Argument is obj : Max-size
    OBJ :: max-size to be handled
    OBJ :: Max-size is 4000 828
    OBJ :: Total command time 12 microseconds
    : Command / Argument is obj : Tile-size
    OBJ :: tile-size to be handled
    OBJ :: Tile-size is 128 128
    OBJ :: Total command time 6 microseconds
    : Command / Argument is obj : Resolution-number
    OBJ :: resolution-number to be handled
    OBJ :: Resolution-number handler returning 6
    OBJ :: Total command time 5 microseconds


    Server: iipsrv/0.9.9
    Cache-Control: max-age=86400
    Last-Modified: Tue, 26 Jun 2012 15:20:05 GMT
    Content-Type: application/vnd.netfpx

    IIP:1.0
    Max-size:4000 828
    Tile-size:128 128
    Resolution-number:6


    Thanks

    aragorniip

     
  • Ruven
    Ruven
    2012-06-29

    Seems to be working fine.The log file says it sent the result correctly.
    However, if there is nothing extra in the log, then you should check in your
    Apache or Lighttpd log to see whether any further requests are made.

     
  • aragorn
    aragorn
    2012-07-12

    Thanks,

    I will try this way. Effectively looks like the fcgi should have some problem.

    Best regards

    aragorn iip

     


Anonymous


Cancel   Add attachments