Device is busy. (I was unable to claim its i

Help
2005-03-14
2013-04-17
  • Hi! I just installed libifp (1.0.0.1-1)  and ifpgui, but everytime I start the application it tells me in the console window "Device is busy.  (I was unable to claim its interface.)" and a dialog box shows up telling me to poweroff my iriver and plug it back in...What is wrong ? (I have libusb 0.1.7)

    Thanks,

    Marcus

     
    • Jim Campbell
      Jim Campbell
      2005-03-18

      As a side note, you will get faster help by posting to the mailing list.
      http://lists.sourceforge.net/mailman/listinfo/ifp-driver-common

      Did you compile libifp?  If so did the self-test pass?
      Can you run ifpline?  It came with libifp. in the examples directory.

      you should be able to run "fipline firmversion" to get the firmware version.

      Also what iRiver model are you using?
      What OS/version are you running?

      -- Thanks Jim
      My e-mail address is in the README ~ line 12
      I check my e-mail more often than this forum.
      Also the maintainer of libifp is active on the mailing list I stated above.  He may be of more help with this problem.

       
    • Jim Campbell
      Jim Campbell
      2005-03-18

      Sorry, typo in the above example.

      The command to run is
      "ifpline firmversion"  and not fipline

       
    • Hi, thanks for your answer! actually I figured out that by running the program as root solved the problem, it worked perfectly fine! I am sorry but I can't tell you what these commands would return (my HDD crashed...) and meanwhile iRiver came out with the UMS firmware (1.30) for the iFP-990, to which I upgraded so the program wouldn't work anymore.

      The OS is FC 1 w kernel 2.4, and the player - iFP-990 - (at that time) was running the 1.00 or 1.08 - I don't really remember - firmware.

      I might get back to the previous firmware (this one is a bit buggy) so do you have an idea how to give access to my driver as a user and not only as root ?

      Thanks again, and great program ! :)

      Marcus

       
      • Oops, I meant 'player' and not 'driver' at the end of my message !

        Marcus

         
    • Jim Campbell
      Jim Campbell
      2005-04-08

      I'm sorry it took so long to respond.

      Yes you can use your player as a non root user by executing the nonroot.sh script that came with ifp_gui-0.6.2.tar.gz.  This script sets up the usb device to be readable by the group "ifp".  You will  then need to add yourself to the "ifp" group.  This is not my script, but one I borrowed from the ifp-driver on sourceforge. 

      What I did to make it work for me was edit one line in the script (nonroot.sh).  There is a line that looks like:
      "chmod g+rw \$DEVICE"
      it is near the middle of the file.  Change it to read:
      "chmod 777 \$DEVICE"
      Then run the script.  This will open the usb device to all users.  This is ok for most desktop systems.

      Let know if you have any more questions.
      Remember feedback is always welcome.  Bugs, enhancements whatever send them.

      Thanks
      Jim