ifpgui on Fedora Core 5 and non-root users

Help
2006-09-16
2013-04-17
  • Hi
    I'm having trouble getting noon-root users access to my iriver.  Running as root works fine.  If I run the ./nonroot.sh it comes up with "This script need hotplugging support."  Google has told me that FC5 no longer uses /etc/hotplug

    Quote from Fedora:

    "The hotplug and device handling subsystem has undergone significant changes in Fedora Core. The udev method now handles all module loading, both on system boot and for hotplugged devices. The hotplug package has been removed, as it is no longer needed.

    Support for hotplug helpers via the /etc/hotplug, /etc/hotplug.d, and /etc/dev.d directories is deprecated, and may be removed in a future Fedora Core release. These helpers should be converted to udev rules. Please see http://www.reactivated.net/writing_udev_rules.html for examples."

    Is there another way?

    Thanks for your help and for wrinting this wonderful proggy, my fionce finally is happy with me changing to Linux. I just need to get my NetMD MiniDisk working now!

     
    • Jim Campbell
      Jim Campbell
      2006-09-19

      I'll need to do more research on this.  At this time I don't have a clue.

      I'll post back if I get it figured out.  This problem has been very elusive.  And very few people can actually make udev and its rules work properly without messing up something else.  I have tried it once.
      http://sourceforge.net/forum/forum.php?thread_id=1410472&forum_id=398616

      But sadly it did not work properly.

      Thanks
      Jim

       
    • No worries. Thanks Jim. Good Luck!

       
    • On my PC I have fixed the problem of using ifpgui as a normal user especially under OpenSuse 10.2 for the iRiver IFP 890. I think it works fine with other modells of the company and hopefully under Fedora Core 5 which I not use, but it may be a hint.

      In the directory "/etc/udev/rules.d" I create a file with the name:
        66-ifgui.rules
      and the contents of:
      KERNEL=="usb", DEVICE=="USB", SYSFS{idVendor}=="4102", GROUP="users"

      You can modify the group or the vendor if necessary.

      regards
      Uwe