Door openings not exported if door object is hidden/filtered out

2013-06-14
2013-09-26
  • Hi,
    We have some issues with door openings in wall elements not exporting to IFC if the door object is hidden.
    In the Revit view, wall openings created by door elements are showing (even if door category is turned off).
    We export using the latest IFC exporter from REVIT 2013 Update 2, using "export only elements visible in view"

    Regards,
    Francois

     
  • Angel Velez
    Angel Velez
    2013-06-14

    We should definitely make this consistent. I'll file a bug report for this.

     
  • Thanks

     
  • Hi,

    Same issue with latest IFC Exporter for Revit 2013 - v2.12.0
    Not working with 2014 out of the box exporter either

    Please do something

     
  • Angel Velez
    Angel Velez
    2013-08-08

    Hello,

    Sorry, we did not get a fix in for the latest exporter. It is on our list, though, and we will get to it in the near future.

    Thanks,
    Angel

     
  • Angel Velez
    Angel Velez
    2013-08-19

    Hi Francois,

    Can you provide a sample file for this? Our internal testing shows that doors that are hidden get the opening, but not the door, exported. But there are many ways to create doors, so we may have missed one. A simple sample file would help a lot.

    Thanks,
    Angel

     
  • Hi Angel,

    Here comes a sample file. Have a look at the 3d view
    Openings do not export to Solibri, because door objects are hidden by the use of a filter.

    Thanks

     
    Attachments
  • Angel Velez
    Angel Velez
    2013-09-25

    Thanks for the file - we will investigate.

     
  • Angel Velez
    Angel Velez
    2013-09-26

    Hi Francois,

    Our latest testing shows that this is indeed a problem with the 2013 exporter, but that the latest 2014 exporter (not the out of the box version) has the issue fixed. I suspect that the issue is partially in internal code that we were able to patch up for 2014 and not 2013. I could investigate further to see if something can be done to patch up 2013, but it seems like not the best use of resources as people migrate to 2014 anyway. So, my questions to you are:

    1. Do you agree that this is fixed in the 2014 updates (not the one that came with Revit)?
    2. Is it very important to you that this is fixed in 2013 also?

    Thanks,
    Angel