Hi Ed,

 

I tried your page under latest drip (build from SVN Source tree). There the calendar works fine. Latest sIEve works as well. I think the latest drip.exe is not available as download. I tried Drip 0.5 which is giving same problems as described by Hristo.

 

Johan.

 

-----Original Message-----
From: ieleak-devel-bounces@lists.sourceforge.net [mailto:ieleak-devel-bounces@lists.sourceforge.net] On Behalf Of Hristo Deshev
Sent:
Wednesday, February 07, 2007 12:22 AM
To: ieleak-devel@lists.sourceforge.net
Subject: Re: [Ieleak-devel] Trouble with dojo's DropdownDatePicker, IE7 support?

 

Hey Ed,

I tried running your page under Drip, but I don't seem to be getting the Access Denied error. The DropdownDatePicker does not initialize and does not work, but I don't get an error. Can you post the exact JS line that throws the error and some of the code around it, so that we have some context.

I don't know why I don't get an explicit error message and I hope the two problems are related. And, yes, my version of the page (almost the same as yours) runs fine without Drip. I am posting it below.

Hristo

============================
<html>
<head>
<script type="text/javascript" src="dojo.js">
</script>

<script type="text/javascript">
   dojo.require("dojo.widget.DropdownDatePicker");
</script>

<title>DropdownDatePicker</title>
</head>
<body>

<div dojoType="dropdowndatepicker"></div>

</body>
</html>
============================

On 2/2/07, Ed <ednotover@gmail.com > wrote:

Greetings,
   Thanks for drip - I've used it on a couple applications and it's been a great help in tracking down leaks.  I've got a question and a problem.
   We haven't moved to IE 7 yet, but it looks like that swap may happen in the next few weeks.  Does drip work with IE 7?
   With drip on IE 6, I'm having trouble working with a dojo widget.  I'm using dojo 0.4.1 (from http://dojotoolkit.org/ ) and IE under drip fails to work with the DropdownDatePicker widget there.  Under vanilla IE (no drip), things work fine.  I've included an example page that shows the issue.  Specifically, what's happening under drip is that I get a permission denied javascript error in the dojo code.  It's not an issue with dojo in general, since I've used drip with other dojo widgets without fail.  Is there something I can do here that will allow drip to proceed?

Thanks,
Ed


<html>
<head>

<script language=javascript src="dojo.js">
</script>

<script>
   dojo.require("dojo.widget.DropdownDatePicker ");
</script>

<title>DropdownDatePicker</title>
</head>
<body>

<div dojoType="dropdowndatepicker"></div>

</body>
</html>

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier.
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Ieleak-devel mailing list
Ieleak-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/ieleak-devel




--
Hristo Deshev
http://blogs.telerik.com/Blogs/twisted_asp_net

***********************************************************************

The information in this message is confidential and may be legally

privileged. It is intended solely for the addressee. Access to this

message by anyone else is unauthorized. If you are not the

intended recipient, any disclosure, copying, or distribution of the

message, or any action or omission taken by you in reliance on

it is prohibited and may be unlawful. Please immediately contact

the sender if you have received this message in error. This email

does not constitute any commitment from Cordys Holding BV or

any of its subsidiaries except when expressly agreed in a written

agreement between the intended recipient and

Cordys Holding BV or its subsidiaries.

***********************************************************************