Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#60 avcodec_encoder.c error on make

v1.0 (example)
closed-fixed
None
5
2015-03-23
2013-11-11
Casey Weederman
No

uname -a:
Linux scorn 3.2.0-4-amd64 #1 SMP Debian 3.2.51-1 x86_64 GNU/Linux
Method: idjc-0.8.12, idjc-0.8.11, idjc-0.8.10 via git clone, manual install from http://sourceforge.net/projects/idjc/
First, c/avcodec_encoder.c complains about fprintf and SUCCEEDED being undeclared, so I comment out lines 349 and 350 of that file. I feel like that shouldn't work, but at least it makes and installs.
I get the profile picker, I hit open, and that's the end of it, except for a runtime error: "sc receive: nothing to receive" (terminal output attached).

I have to go back to 0.8.9 to escape the avcodec_encoder error and the nothing to receive error. I'm not sure they're related, but I'm not sure they're not. Google hasn't been helpful, but these threads suggest avcodec has been plaguing you.
Any idea what I'm doing wrong? I'd be happy to include any more information about this. I'm going to keep tinkering with it.

Thanks!
-Casey

1 Attachments

Discussion

  • I suggest you try the latest git and report back, this time with a working attachment if you have problems. I fixed a couple of things that would cause problems when building with ./configure --disable-libav. I didn't even know that was broken.

     
    • That worked perfectly, and without --disable-libav. Thanks!

       
    • status: open --> closed-fixed