#1 Library requirements (shout >= 2.0) not met

open
nobody
5
2004-10-18
2004-10-18
Anonymous
No

SHOUT library
checking for pkg-config... /usr/bin/pkg-config
checking for shout >= 2.0... Package shout was not
found in the pkg-config search path.
Perhaps you should add the directory containing
`shout.pc'
to the PKG_CONFIG_PATH environment variable
No package 'shout' found

configure: error: Library requirements (shout >= 2.0) not
met; consider adjusting the PKG_CONFIG_PATH
environment variable if your libraries are in a
nonstandard prefix so pkg-config can find them.

xxx@www:~/icegen$ locate shout.pc
/usr/local/lib/pkgconfig/shout.pc

What im doin wrong??

Discussion

  • Logged In: YES
    user_id=747963

    Try launch this command:

    pkg-config --cflags shout

    if it goes right, send me your config.log file.

    If it fails, your shout.pc is missing or wrong. Try fix it.

     
  • Logged In: NO

    www:~# pkg-config --cflags shout
    Package shout was not found in the pkg-config search path.
    Perhaps you should add the directory containing `shout.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'shout' found

     
  • Logged In: YES
    user_id=747963

    Check if pkg-config searches into /usr/lib/pkgconfig, and,
    if so, copy into it your shout.pc file and re-configure iceg.

     
  • hi you really wanna try "libshout3-dev" worked for me

    "sudo apt-get install libshout3-dev"