Hello everyone

Today i installed ttyd on machine A(hylafax) and
termnetd on machine B(iaxmodem).

On machine B,
i added "3002:on:/dev/ttyIAX0:B19200 CLOCAL CREAD IGNBRK;" to file "/etc/termnetd.conf",
then i ran cmd "termnet -c /etc/termnetd.conf",it worked well.

On machine A,
i ran cmd "ttyd -d /dev/ptmx -b 19200 -p 8NC0 172.16.16.213 3002 ".
"172.16.16.213" was machine B's IP address and
"3002" was the opened port number.

Now,when i ran "echo "testtest" > /dev/pts/2" on machine A,
the machine B's iaxmodem's console output is "testtest".
So,i think the connection is ok.

But when i want to add the modem "/dev/pts/2" using "faxaddmodem /dev/pts/2" on machine A,
there is an error below:
   -----------------------------------------------------------------------------------------------------------------------------
Probing for best speed to talk to modem: 38400 19200 9600 4800 2400 1200
Unable to deduce DTE-DCE speed; check that you are using the
correct device and/or that your modem is setup properly.  If
all else fails, try the -s option to lock the speed.
   -----------------------------------------------------------------------------------------------------------------------------

Can anyone tell me what the problem is?
Thanks.

Jack Tan


2014-02-23 10:36 GMT+08:00 Jack Tan <hitbittyboy@gmail.com>:
Thanks for your reply.

I know your meanning,
and i will try and report the result.

Jack Tan


2014-02-23 10:00 GMT+08:00 James Cloos <cloos@jhcloos.com>:

Just to provide more detail, hylafax talks to iaxmodem over a pty, just
as hyla would talk to a hardware modem over a tty (serial or usb link).

If you don't have asterisk ported to aix, you can leave it on a linux
box.  It will help if the two boxen have a private point-to-point
ethernet link, but things will still work through a decent switch.

-JimC
--
James Cloos <cloos@jhcloos.com>         OpenPGP: 1024D/ED7DAEA6