Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

iaxmodem send problem

Help
YanOtt
2011-06-14
2013-04-05
  • YanOtt
    YanOtt
    2011-06-14

    Asterisk 1.6.2.17.3
    iaxmodem 1.1.1
    hylafax-5.2.5

    I setup modem, hylafax, extension, sip.
    I can receive fax.
    But i can't send fax. Fax go to queue, but not send.

    Jun 14 23:01:24.18: : SESSION BEGIN 000000030 3907483
    Jun 14 23:01:24.18: : HylaFAX ™ Version 5.2.5
    Jun 14 23:01:24.18: : SEND FAX: JOB 2 DEST 3907483 COMMID 000000030 DEVICE '/dev/ttyIAX0' FROM 'root <root@>' USER root
    Jun 14 23:01:24.18: : STATE CHANGE: RUNNING -> SENDING
    Jun 14 23:01:24.18: : <-
    Jun 14 23:01:24.18: : ->
    Jun 14 23:01:24.18: : MODEM set XON/XOFF/FLUSH: input ignored, output disabled
    Jun 14 23:01:24.21: : DIAL 3907483
    Jun 14 23:01:24.21: : <-
    Jun 14 23:02:09.21: : ->
    Jun 14 23:02:09.21: : SEND FAILED: JOB 2 DEST 3907483 ERR No answer from remote {E003}
    Jun 14 23:02:10.21: : <-
    Jun 14 23:02:10.21: : ->
    Jun 14 23:02:10.21: : MODEM set DTR OFF
    Jun 14 23:02:10.21: : MODEM set baud rate: 0 baud (flow control unchanged)
    Jun 14 23:02:10.21: : STATE CHANGE: SENDING -> MODEMWAIT (timeout 5)
    Jun 14 23:02:10.21: : SESSION END
    ~

    I'm not see any information in Asterisk CLI, iax2 debug or sip debug about that attempts.
    IAXModem not connect to Asterisk when send fax.

     
  • YanOtt
    YanOtt
    2011-06-14

    Problem is resolved.

    Likely that if IAX peer isn't numerical IAXmodem not connect to Asterisk when send fax.
    That sound strange.