Devolution Security 3.0.6 released

This version has been tested with Ubuntu 5.04

This (and all previous versions) required 24 bit depth display.

Posted by Peter Hartshorn 2005-10-26