Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#4563 [HHQ-4522] Cannot start agent on zlinux; unable to locate bi

Bug
open
Hyperic Team
None
5
2012-10-09
2010-12-17
Hyperic Team
No

http://jira.hyperic.com/browse/HHQ-4522
Cannot start agent on zlinux; unable to locate binaries.



When installing the nojre agent on zlinux, starting the agent fails and reports:



$ ./hq-agent.sh start


Unable to locate any of the following binaries:


  /opt/hyperic/4.5-EE-GA/hyperic-hqee-agent-4.5/wrapper/sbin/../../wrapper/sbin/wrapper-linux-s390x-32


  /opt/hyperic/4.5-EE-GA/hyperic-hqee-agent-4.5/wrapper/sbin/../../wrapper/sbin/wrapper-linux-s390x-64


  /opt/hyperic/4.5-EE-GA/hyperic-hqee-agent-4.5/wrapper/sbin/../../wrapper/sbin/wrapper



The binaries could not be located as they really do no exist.



The variable HQ_JAVA_HOME is set to use:



$ $HQ_JAVA_HOME/bin/java -version


java version "1.6.0"


Java(TM) SE Runtime Environment (build pxz6460sr1-20080419_01(SR1))


IBM J9 VM (build 2.4, J2RE 1.6.0 IBM J9 2.4 Linux s390x-64 jvmxz6460-20080416_18762 (JIT enabled, AOT enabled)


J9VM - 20080415_018762_BHdSMr


JIT - r9_20080415_1520


GC - 20080415_AA)


JCL - 20080412_01



The platform details are:



$ uname -a


Linux xxxxxxx.dfw.ibm.com 2.6.18-92.el5 #1 SMP Tue Apr 29 13:16:58 EDT 2008 s390x s390x s390x GNU/Linux




Expected Result:


Able to install and successfully start an agent on supported platforms.



Actual Result:


Not able to successfully start an agent on zlunix.



Steps to Reproduce:


1. Install Hyperic agent on zlinux.


2. Export HQ_JAVA_HOME to use existing java.


3. Start agent.


4. Note the agent fails to start and reported message received.



Additional Information:


Same results received with 4.5.1 agent.



According to the Java Service Wrapper 3.5.0 release notes, support for zLinux 32 and 64-bit on s390 and s390x systems was added.

Discussion


Anonymous


Cancel   Add attachments