Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#182 ABI breakage in 1.2.15/1.3.0?

open-accepted
nobody
None
5
2011-02-16
2011-01-28
Anonymous
No

When lookging over a diff 1.2.15 -> 1.1.25/1.3.0 I see this:

@@ -152,7 +159,7 @@
void setcminmax(int * cmin, int * cmax, const char * word, int len);
struct hentry * compound_check(const char * word, int len, short wordnum,
short numsyllable, short maxwordnum, short wnum, hentry ** words,
- char hu_mov_rule, char is_sug);
+ char hu_mov_rule, char is_sug, int info);

int compound_check_morph(const char * word, int len, short wordnum,
short numsyllable, short maxwordnum, short wnum, hentry ** words,

hentry unfortunately is a public: truct, though there wasn't a SONAME bump here?

Discussion

  • rene means 1.2.14 -> 1.2.15/1.3.0 of course.

     
  • These public functions are not parts of the Hunspell API (see man 3 hunspell), but the potential incompatiblity was one of the reasons of version 1.3.0. Unfortunately, I couldn't modify the real library version numbering. I believe, practically it is not a real problem, but I wait for your and Caolan's help or decision. Thanks in advance.

     
  • libhunspell of release 1.3.2 library has got minor version number 3. What is your suggestions?

     
    • status: open --> open-accepted