[b98b7d]: INSTALL Maximize Restore History

Download this file

INSTALL    84 lines (61 with data), 2.6 kB

Overview:

These are UNIX only instructions, but they might also work with a proper mingw or
cygwin system, that has support for all the needed requirements.

hugin uses the following libraries. make sure that they are completely
installed (including dev packages)

REQUIRED LIBRARIES/PACKAGES:

 - wxwindows 2.4.0 or higher (libary and development packages)
    
    wxWidgets >= 2.6 is recommended

    Special instructions for wxWindows 2.4.x:

      hugin uses the XRC extension of wxwindows to build its
      dialogs.

      the XRC extension needs to be installed. You might
      need to install a wxwin-contrib (debian) or similar package if provided
      by your distribution, since most distributions do not include it
      in their default package.

      If you compile wxwindows from scratch, go to the contrib/src/xrc folder
      and compile and install xrc from there.

 - Panorama tools. Please DO NOT USE the versions from the original site.
   I'm using the version maintaned on sourceforge, http://panotools.sf.net

   Prebuild packages are available from:
    http://www.photocreations.ca/panotools/index.html (windows builds)
      or
    http://bugbear.blackfish.org.uk/~bruno/panorama-tools/ (linux rpm & sourcecode)

 - make,
 - boost, get it from www.boost.org
    The headers and the boost thread library are required
 - gcc (tested with 3.2, 3.3, 3.4 and 4.0)


Required packages building for debian:
 libwxgtk2.6-dev libpano12-dev libboost-dev libboost-graph-dev libboost-thread-dev libboost-thread

COMPILATION:

These are the instructions for linux. see the WINDOWS_COMPILE.txt
if you compile on windows.

If you use the CVS source, please read HACKING before continuing

do the following in the hugin directory:
$ ./configure
   Configure might get confused if wxWindows 2.4 and 2.5 is installed
   at the same time (especially on debian).
   For example, debian ships wxWindows 2.5 as unicode enabled, so use
   ./configure --with-unicode=yes, else it configure will mix 2.4 and 2.5.

   Other important configure switches include:
      --disable-desktop  Disable calling update-mime-database
                         This is useful if update-desktop-database
                         fails. This can happen if a nonstandart --prefix
                         has is used.

$ make
$ make install

If you need to compile wxWindows, please use the following steps:
$ bzip2 -dv wxGTK-2.4.2.tar.bz2
$ cd wxGTK-2.4.0
$ ./configure --with-gtk --with-opengl
$ make
$ cd contrib
$ ./configure
$ make
$ cd ..
$ su  ( login as root )
$ make install
$ cd contrib
$ make install
$ ldconfig
$ exit  ( exit the root mode )