Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Partage Internet

Jerome
2011-05-28
2013-04-29
  • Jerome
    Jerome
    2011-05-28

    Bonjour,
    Tout d'abord un grand bravo et merci. Je découvre juste ce soft et c'est exactement ce que je recherchais. Mais j'ai un petit problème. Le partage en réseau local fonctionne parfaitement, en revanche pas le partage Internet. Habitué de ces petits désagrément de réseau, j'ai vérifié mes options de pare-feu (meme parefeu désactivé). Tout semble OK, surtout que tout passe bien en local. Je me dirige ensuite sur mon routeur, j'ouvre le port tcp (j'ai modifié le port par défaut) et rien ne se passe.
    J'utilise également le logiciel Hamashi qui permet de créer des réseaux privés via internet et sans se soucier des routeurs, et là toujours pas de partage actif. Pourtant jusqu'à maintenant, tous mes problèmes similaires étaient au moins résolus avec Hamashi.

    Je ne sais que faire. Est-ce que j'aurai loupé un détail ?

    bref, si une âme charitable pouvait m'éclairer :)

    Merci

     
  • Jerome
    Jerome
    2011-05-28

    Hmm, je ne vois pas de bouton "éditer".
    J'ai oublié de préciser :
    - version 1.1 http-explorer
    - firefox 4, IE9, Safari 5
    - Win 7

     
  • kroman_fr
    kroman_fr
    2011-05-28

    Bonjour,

    Merci pour ton message !

    Peux tu démarrer http exporer avec la commande suivante :

    hexplorer.exe /debug

    Ensuite peux tu voir si des événements s'ajoutent dans la fenêtre du debug lorsque tu tentes d'y accéder depuis l’extérieur?

    Quel routeur/box as-tu?
    As-tu plusieurs cartes réseau?
    Tente-tu bien d'y accéder via l'IP internet?

    Eddy

     
  • Jerome
    Jerome
    2011-05-28

    Re bonsoir,
    J'ai donc lancé le mode debug.Il n'y a rien de plus que les lignes initiales. La derniere étant "Add systray icon". J'ai comparé avec le lancement en local et en effet j'ai vu la différence.
    - J'ai une sfr-box (NB4-FXC-r2).
    - une seule carte réseau physique, mais plusieurs virtuelles (VirtualBox, Hamashi…)
    - Oui je me connecte à partir de mon ip FAI ou celle donnée par Hamashi.

    Je ne pense pas que cela vienne du parefeu, vu que j'ai ouvert les ports et que même le parefeu désactivé, ca ne passe pas.
    Ayant redirigé le port sur le routeur, ca ne devrait pas venir de là (enfin j'imagine, j'avoue que mes connaissances en réseau sont assez sommaires) ou alors j'ai oublié un détail quelque part… Le logiciel Hamashi (je ne sais pas si tu le connais) permet justement de passer outre les problemes de configuration routeur.

    Bref je suis perdu là. Ca ne me surprendrai pas de découvrir que j'ai oublié un truc, mais là je vois pas quoi.

    Merci :)

     
  • Jerome
    Jerome
    2011-05-31

    Petite évolution.
    J'ai essayé sur un win XP, j'ai toujours le problème d'accès via mon ip FAI, en revanche via l'ip d'Hamachi  cela fonctionne.
    J'avoue que je sèche là.

     
  • kroman_fr
    kroman_fr
    2011-06-01

    Bonjour,

    Désolé pour le temps de réponse j'étais en vacance.

    Si ça ne fonctionne que par l'intermédiaire d'un logiciel c'est qu'il y  a un problème avec la redirection de port. Pourrai-tu me faire une capture de la redirection de port que tu as fais dans ta box?

     
  • Jerome
    Jerome
    2011-06-01

    Pas de soucis pour le délai. Heureusement qu'on a une vie :)
    C'est bien ce que je me dit. Quoique ca ne fonctionne pas que l'intermédiaire du soft, puisque sous win7 même avec le soft ça ne passe pas.
    Voila mes parametre routeur pour http-explorer. (je n'ai mis que http-explorer, mais si tu veux la totalité je remets)

    192.168.1.20 correspond à mon pc (win7) et 192.168.1.53 c'est le pc virtuel avec XP
    J'ai même essayé en redirigeant les ports UDP (les même que tcp), bien que à priori pas nécessaire, puisque sur la page de redirection il n'est précisé d'ouvrir que le port tcp.

    Donc pour résumer (au cas où je n'ai pas été très clair) :
    => Sous Win 7 (pc physique) :
    - accès ok par 192.168.1.20:port
    - pas d'accès par ip FAI
    - pas d'accès par ip Hamachi (5.x.x.x)

    => Sous Win XP (PC virtuel) :
    - accès ok par 192.168.1.53:port
    - pas d'accès par ip FAI
    - accès OK par ip Hamachi (5.x.x.x)
    Les paramètres parefeu doivent être bon puisque selon que je les mets ou non, l’accès 192.168.1.X fonctionne ou non)

     
  • kroman_fr
    kroman_fr
    2011-06-01

    Ça m'a l'air bon pourtant…

    Certains routeurs/box ne permettent pas d'accéder à une hôte locale depuis son propre réseau local via l'ip Internet. Donc as-tu tenté l’accès depuis un poste sur internet (en clair qui n'est pas connecté sur ta box) par ex depuis un téléphone 3g ou chez un ami ?

    Peux-tu tester avec une autre appli même d'un usage différent (par ex un serveur FTP ou un autre serveur web lite) sur ton PC physique sans passer par une application tiers (normalement tu n'en as pas besoin quand tu as accès à l'interface admin de ta box).

    As-tu bien un IP locale fixe?

     
  • Jerome
    Jerome
    2011-06-02

    J'utilise occasionnellement fillezilla serveur ou vlc (en serveur) sans problème (c'est pour ça que j'étais assez confiant sur mes paramétrages du routeur). De même  je peux également héberger des parties de jeu réseau. Ce qui me perturbe le plus, c'est que meme sous Hamachi ça ne passe pas. Ce soft est censé justement permettre de créer des réseau sans etre confronté à ces problemes (je vais essayer de voir sur ses forums aussi). Et surtout pourquoi sous XP Hamashi passe et pas sous Seven.
    Je n'ai pas accès dans l'immédiat à une autre source d'internet, donc je ne peux pas tester autre chose et pour répondre, oui mes ip locales sont fixes (attribuées par dhcp)

    Pour le moment je vais rester avec ce brciloage, à savoir lancer TTP-Serveur via Hamashi sur le PC virtuel. Ca va que je n'en ai besoin que occasionnelement, car ça va etre lourd à gérer tant que j'ai pas résolu ce probleme.

    Je tiendrai au courant de l'évolution. Et si quelqu'un utilise Http-Explorer sous Seven ou avec SFR comme FAI peut faire remonter son expérience, ca m'aiderait peut etre.

    En tout cas merci Kroman. et si tu vois d'autres pistes à explorer je suis preneur.

     
  • Jerome
    Jerome
    2011-06-02

    Lorsque je dis que mes ip locales sont fixes (attribuées par dhcp), je veux dire que le dhcp est activé mais que l'ip de mon PC est attribuée à l'adresse MAC de ma carte réseau. (ne connaissant pas assez les réseaux, je ne sais pas si cette précision est utile ou a un sens)

     
  • Jerome
    Jerome
    2011-06-02

    Suite et probablement fin de l'histoire. Après recherche et discussion il semblerait que en effet comme tu le disais je ne puisse pas tester en local depuis mon ip fai. J'ai eu la confirmation sur le forum de SFR.
    Je ne peux pas tester en extérieur pour le moment, mais je ne vois que ça comme problème.

    Merci encore

     
  • kroman_fr
    kroman_fr
    2011-06-02

    Il existe un moyen très simple de tester la connectivité depuis l’extérieur : traduire la page suivante dans google :

    http://ton_ip_fai:port/

    Sinon si ton pc est allumé 24/24 tu peux m'envoyer ton IP:PORT par mail sur le site ;)

    Si c'est bien ça, tu peux contourner en liant l'ip FAI à l'ip locale dans le fichier HOST de windows dans le cas où le routeur ne fait pas le lien entre les deux adresses.

     
  • Jerome
    Jerome
    2011-06-03

    Je vais essayer de voir ça. Et sinon je t'envoie un message. Pour être honnête j'y pensé hier. J'avais même commencé à le rédiger, mais je me suis dit que j'allais pas t’embêter plus.
    :)

     
  • kroman_fr
    kroman_fr
    2011-06-03

    C'est bon ça marche :)

    Pour le problème avec "déconnexion", peux-tu ouvrir la console d'erreur dans firefox et me dire si tu vois une erreur javascript lorsque tu cliques dessus?

    Pour le problème de plantage hélas il me faudrait plus d'infos (l'idéal serait de trouver l'action exacte effectuée pour provoquer ce plantage). Sur le court terme ça sera pas évident mais si tu utilises l'appli régulièrement tu trouvera je pense le déclencheur de cette erreur.

    Eddy

    PS : je réponds ici car j'ai un mail de retour d'adresse inexistante.

     
  • Jerome
    Jerome
    2011-06-03

    En effet j'ai le fichier OK.jpg :). Super.

    En ce qui concerne la déco, voici le retour de la console lorsque je clique sur "déconnecter":

    Erreur : Url is null
    Fichier Source : http://192.168.1.20:2025/?res=common/common.js
    Ligne : 365

    Pour le plantage, pas de soucis, je verrai sur le long terme. Et si je trouve le déclencheur je t'en ferai part.

     
  • Jerome
    Jerome
    2011-06-03

    Je t'ai fais une petite capture video de l'erreur en question si ca peut t'aider (même adresse, mes login/mdp). Ca se produit lorsque je valide la modification du partage. Mais ca ne le fait pas sur tous les partages. Je contourne ce probleme en créant les autorisations des la création du partage.

     
  • kroman_fr
    kroman_fr
    2011-06-03

    As-tu laissé les paramètres des cookies par défaut dans Firefox? Http explorer arrive t-il à écrire des cookies dans firefox lors d'un login (outils > option > vie privée > afficher les cookies) et les supprime t-il lorsque tu cliques sur "déconnexion" malgré l'erreur javascript?

     
  • Jerome
    Jerome
    2011-06-03

    Les cookies n'étaient pas supprimés. Je les ai supprimés manuellement, et je peux à nouveau déconnecter.
    De plus, il semble que les cookies soient de nouveau supprimés à la déconnexion.
    Il a du y avoir un petit couac. J'ai eu un "probleme" tout à l'heure (les problemes fréquent sous windows) à savoir que dès que je lançais Http-explorer, il plantait aussitot. Un reboot a remis tout dans l'ordre. Peut etre que ca a planté les cookies à ce moment.
    Bref, tout fonctionne bien et au cas où ca recommence, je penserai aux cookies.

    Je pense avoir terminé de d’embêter (pour rester correct ^^) avec mes soucis. Je vais maintenant pouvoir me consacrer à l'utilisation :)

    Merci encore.

     
  • kroman_fr
    kroman_fr
    2011-06-03

    pour l'erreur sur la modification des partages : parfait, une erreur systématique reproduite du premier coup chez moi également :D

    bientôt la 1.11 revision 3 (la semaine prochaine)

    merci encore pour ce debugage et n'hésites pas si tu vois encore un bug (ou si tu as de nouveau un problème avec le bouton "déconnexion")

     
  • Jerome
    Jerome
    2011-06-04

    Ah ben super. Content d'avoir au moins apporté un petit quelque chose et de ne pas être que demandeur d'aide :)
    Je suis un utilisateur convaincu du libre et il est normal de faire remonter toutes les infos concernant le fonctionnement au développeur. Surtout lorsque le dev est sympathique et  si réactif aux demandes de ses utilisateurs ^^.

    Bref bon WE et bonne continuation.