Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

unable to build the project

Help
2008-11-05
2013-04-15
  • Hi,

    i am getting this error while making a build for the project.

    D:\hivemind-dev>ant -f bootstrap.xml
    Buildfile: bootstrap.xml

    init.core:

    configure:

    BUILD FAILED
    D:\hivemind-dev\bootstrap.xml:130: Core tasks are not available. Expects ../el4a
    nt/lib/buildsystem-core.jar or in Ant lib/ directory.

    I am unable to find this file buildsystem-core.java. Please let me know how to create this jar file.

    Thanks.
    Krish

     
    • Still struggling to build the project :)
      it seems some issue with el4ant.
      found buildsystem-core.jar, it is present in the lib directory.
      but got new errors while building the project

      configure:
      Plugin version 0.9.3 does match the build system version 0.9.3head in jar:file:/
      D:/ant+el4ant+helloworld_0.9.3/el4ant/lib/buildsystem-core.jar!/META-INF/MANIFES
      T.MF. Plugin is ignored !

      will update with more findings.

      Regards
      Krish

       
    • Hello Krish,

      first of all, sorry for my late answer (I don't understand why your question was not forwarded to my mail, I got to check this forum a few days ago and found your post).

      My first question would be: where did you get el4ant from? Did you get the SVN head from sourceforge? Did you apply my patches?

      As mentioned in the development page of hiveboard web site (http://hiveboard.sourceforge.net/web/development.html), you have to get el4ant revision 373 (not sure that's the latest revision now), and then apply the patches that are part of hiveboard distribution (in doc/el4ant-hiveboard.patch).

      I don't think the official el4ant (either release or even latest trunk) can work to build hiveboard, that's why it is required to apply the patches I have made.

      I'll wait for your feedback on these points, then we can try to progress on having hiveboard successfully build on your system.

      Cheers

      Jean-Francois

       
    • Hi Jean,

      Yes you are correct i had downloaded the official version of el4ant and not applied the patch to it.

      Am not quite sure how to apply the patch to el4ant.

      it seems from your reply that i need to checkout el4ant code form SVN and then place the patch in build directory and make the build?

      will try this out and let you know.

      Thanks for your reply.

      Regards
      Krish