Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

librexxtrans.so RPM dependency problem

Help
Seitz
2007-03-15
2013-05-23
  • Seitz
    Seitz
    2007-03-15

    The RPM package "THE-X11-3.2-1.i386.rpm" contains a dependency on
    "librexxtrans.so". But the RPM package for Rexx/Trans,
    "RexxTrans-1.8-1.i386.rpm", says it provides "librexxtrans.so.1.8".
    Because of this mismatch, I cannot install "THE-X11-3.2-1.i386.rpm" with
    "RexxTrans-1.8-1.i386.rpm".

    rpm --test -Uhv THE-X11-3.2-1.i386.rpm RexxTrans-1.8-1.i386.rpm
    Regina-REXX-3.3-1.i386.rpm PDCurses-2.8-1.i386.rpm
    error: Failed dependencies:
    librexxtrans.so is needed by THE-X11-3.2-1.i386

    rpm -qp --provides RexxTrans-1.8-1.i386.rpm
    RexxTrans
    librexxtrans.so.1.8
    RexxTrans = 1.8-1