This WinTV card has been driving me nuts.  I had the thing working in Redhat 5.2 and 6.1.  In 6.1, xawtv worked well, but bcast2000 couldn't make the sound come out of the card.  I've recently upgraded the kernel from 2.2.14 to 2.2.17 and now the sound works in bcast2000. Yeah!  However, the tuner no longer functions.  (F***)  Has anyone seen this?  I've recompiled the driver, but the results are the same.  There's a few strange errors that I can't chase down..

From what I've read, the i2c.o is the bus that this card runs on.  It's also supposed to detect the tuner.  When I type the following:

# /sbin/depmod -ae
/lib/modules/2.2.17-14/misc/i2c.o: unresolved symbol(s)
        __udelay
        kmalloc
        kfree
        printk

It sure seems like this is hosed up?  Any kernel people out there know if this could be the cause?

I insmoded the card the same way it was last time:
insmod videodev
insmod i2c verbose=1 scan=1 i2c_debug=0
insmod tuner debug=1 type=2
insmod msp3400
insmod bttv radio=0 card=10

However, the tuner doens't look like it was recognized.  I've tried every different tuner in the list?
# /sbin/lsmod
Module                  Size  Used by
bttv                   36568   0  (unused)
msp3400                10016   0  (unused)
tuner                   1964   0  (unused)
i2c                     3360   3  [bttv msp3400 tuner]
videodev                2368   2  [bttv]
 

My  /etc/modules.conf:
#TV
alias   char-major-81   bttv
pre-install bttv insmod;  modprobe -k tuner; modprobe -k msp3400
options bttv radio=0 card=10
options tuner type=2
 

The bootup used to say this:
i2c: bus registered: bt848-0
i2c: scanning bus bt848-0: found device at addr=0xa0
i2c: scanning bus bt848-0: found device at addr=0xc2
i2c: device attached: tuner (addr=0xc2, bus=bt848-0, driver=tuner)

Now it says this:
i2c: initialized (i2c bus scan enabled)
i2c: driver registered: tuner
i2c: driver registered: msp3400
i2c: bus registered: bt848-0
 

It doesn't seem to get the "tuner=2" option passed to the module.  Is there a way to force it?
Any help would be appreciated.

Dan Naughton