ActiveMQ Examples

Help
Selector
2004-08-17
2004-08-25
  • Selector
    Selector
    2004-08-17

    Hello all,
    I'm currently trying to view the Queue from one of ActiveMQ's examples on Linux. The instructions here -> http://activemq.codehaus.org/Hermes+Jms under the 'Configure an ActiveMQ Session' section make sense, but I'm unable to add a property to the ActiveMQConnectionFactory. After I right click, both 'Add Property' and 'Remove Property' are grayed out.

    Any ideas? Any help would be greatly appreciated. Thanks in advance.

     
    • Colin Crist
      Colin Crist
      2004-08-18

      Look at the hermes.log file, its possible Hermes cannot instantiate this factory because you've not got all the dependent libraries configured correctly.

      The ActiveMQ site lists the libraries you need.

      Cheers,

      Colin.

       
    • Selector
      Selector
      2004-08-18

      Thanks! You were right about the libraries being configured improperly. However, I'm still having trouble seeing messages on my ActiveMQ queue.

      My properties in the Preferences window are as follows:
      brokerURL = tcp://localhost:61616
      useEmbeddedBroker = false

      My destination is:
      subject    subject    QUEUE

      The only thing out of the ordinary in Hermes.log is:

      2004-08-18 16:19:58,429 [Thread:TcpTransportChannel: Socket[addr=localhost/127.0.0.1,port=61616,localport=48167]] DEBUG org.codehaus.activemq.transport.tcp.TcpTransportChannel - The socket peer is now closed
      2004-08-18 16:19:58,433 [Thread:TcpTransportChannel: Socket[addr=localhost/127.0.0.1,port=61616,localport=48167]] WARN  org.codehaus.activemq.transport.tcp.TcpTransportChannel - Caught while closing: java.lang.ClassCastException. Now Closed

      I feel close!

       
    • Colin Crist
      Colin Crist
      2004-08-25

      Not sure what this is, some odd exceptions here for sure. ClassCastException is always a bug!

      Is it still a problem in the latest ActiveMQ? If so pls send me the entire log.

      Thanks,

      Colin.