Hello,

I have a Universal build of Meteo ready, but I'd like to make sure that it works before releasing it to the world.

I need the following testers:
*Mac OS X 10.3.9 Users
*Mac OS X 10.4.x Users
*Intel Mac Users

If you are interested in testing, please email me at joecrow\at\users\.sourceforge\.net - please include your OS version and if you are on PPC or Intel.

The Universal build of Meteo is not compatible with OS X < 10.3.9. Sorry!

-Joe