Meteo 1.6 crashes on start up OS 10.6.8 Intel

Help
2012-11-23
2013-05-23
  • Mac Pro 1,1, OS 10.6.8
    Meteo will not start 1.6 will not start up.  It crashes every time I start up my machine.  Will not start if double clicked

     
  • Roger Wilmut
    Roger Wilmut
    2012-11-23

    I get exactly the same thing. Tried trashing the prefs: no change. 2008 24 inch iMac running 10.6.8

     
  • mzinformed
    mzinformed
    2012-11-23

    Same experience for me. 2008 24 inch iMac running 10.6.8

     
  • CrusherMcSwain
    CrusherMcSwain
    2012-11-23

    Same for me, double click on Meteo Icon, it looks like it starts to expand, then nothing. Mac 2.5 GHz Intel Core i5 running MacOS 10.6.8. I like this program. Let me know how to get this running or what the fix is.

     
  • Stan
    Stan
    2012-11-23

    Same here on Intel with 10.6.8.  I went inside the package contents>MacOS > and ran Meteorologist and Terminal gave me this:
    /Applications/Meteorologist.app/Contents/MacOS/Meteorologist ; exit;
    . . . /Applications/Meteorologist.app/Contents/MacOS/Meteorologist ; exit;
    Illegal instruction
    logout

     
  • Ray Nehem
    Ray Nehem
    2012-11-23

    Same her on intel MacBook Pro Mac with OS 10.6.8 v1,6 does run.  So reverted to 1.5.6.

     
  • bart309
    bart309
    2012-11-23

    Are you all getting the radar with either the new version OR v. 1.5.6?  I can't get it with the old version, and don't want to install the latest version until the radar functions with it.

     
  • Ray Nehem
    Ray Nehem
    2012-11-23

    I meant to say it does not run

     
  • EdwardD20
    EdwardD20
    2012-11-23

    My apologized to all. I didn't realize the current Xcode won't support 10.5 or 10.6. I'm working to sort this out. And for 10.7 not being support, again my mistake.

    But if you have 10.8, it works. ;)

    Watch for 1.6.1 shortly.

    Ed

     
  • xyzzy
    xyzzy
    2012-11-23

    Stupid question - where are these new experimental (i.e., 1.6.x) versions being posted?  Looking over recent posts I only see "1.6… doesn't work" but I can't find how it was known it was created in the first place nor where.  Only that you ( edwardd20) was have problems rebuilding from the sources.

     
  • xyzzy
    xyzzy
    2012-11-23

    Oops, just saw it appear on macupdate.com.  Followed its links to sourceforge and  found it's "home".  Still curious how folks knew it was there in the first place prior to this.

    Incidentally I still use 10.6.5 so I hope this thing will still launch when all the dust settles.

     
  • EdwardD20
    EdwardD20
    2012-11-23

    It was not intended to be experimental. I was able to combine the source changes from Google with the source changes SourceForce source changes and get it to build with Xcode 4.5.2. I did post that somewhere here @ SourceForce.

    I had gotten a new MBP and lost my old Xcode (that included 10.6) support. Took a while to find how to get that piece again.

    I will admit I screwed up on this release. If you're running 10.7/8 it works fine but that was not the intent. I'm working today to try and get the pieces all working together again. Right now I'm struggling with CURLHandle not working with 10.6.

    To answer your question, I backed off the 1.6.0 version and reverted 1.5.6 back to the default version. If you want to play with 1.6.0, visit here: https://sourceforge.net/projects/heat-meteo/files/Meteo/Meteo%201.6.0/.

    Ed

    It really seems like Apple made a break in their minds between 10.5/6 and 10.7/8.

     

  • Anonymous
    2012-11-23

    Thanks Edward, I figgered it was something like that. I wanted to let you know that, as an IT professional, your app is a default install on every computer I set up and every user that I work with LOVES it! :)

     
  • xyzzy
    xyzzy
    2012-11-23

    > It really seems like Apple made a break in their minds between 10.5/6 and 10.7/8.

    You think? :-) 

    Personally I don't have any current plans to move past 10.6.5 (or maybe to 10.6.8 if I convince myself that Little Snitch 3 can fully block the app store software from calling home - haven't tried that yet  - don't want the app store and I don't want to loose some key ppc programs I use - so no dumbed down  Lion).

     
  • Wladyslaw Los
    Wladyslaw Los
    2012-11-24

    On my MacBook Pro (13' 1.8 GHz IntelCore i7 16 GB RAM OS X 10.7.5) Meteoroligis5 1.6 starts up only if 32 bit mode is set in it's info panel.

     
  • DParsons
    DParsons
    2012-11-24

    Will not start. Mac Mini Intel Core 2 Duo 10.6.8

     
  • Stan
    Stan
    2012-11-24

    "On my MacBook Pro (13' 1.8 GHz IntelCore i7 16 GB RAM OS X 10.7.5) Meteoroligis5 1.6 starts up only if 32 bit mode is set in it's info panel."

    I was hoping this would be my solution (MB 15" OS X 10.6.8 Intel Core i7), but alas it didn't help. Meteo crashes and files a crash log, which doesn't say anything of value.

    But Ed, thanks for all your time working on this. Hopefully no one asks for a refund . . .

     
  • Stan
    Stan
    2012-11-24

    I just got a better crash report if it helps anyone:
    Process:         Meteorologist
    Path:            . . ./Meteorologist.app/Contents/MacOS/Meteorologist
    Identifier:      com.heat.meteo
    Version:         ??? (???)
    Code Type:       X86 (Native)
    Parent Process:  launchd

    Date/Time:       2012-11-24 08:25:19.283 -0500
    OS Version:      Mac OS X 10.6.8 (10K549)
    Report Version:  6

    Exception Type:  EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread:  0

    Dyld Error Message:
      Library not loaded: /usr/lib/libcurl.4.dylib
      Referenced from: . . ./Meteorologist.app/Contents/MacOS/../Frameworks/CURLHandle.framework/Versions/A/CURLHandle
     
    Reason: Incompatible library version: CURLHandle requires version 7.0.0 or later, but libcurl.4.dylib provides version 6.0.0

    Binary Images:
    0x8fe00000 - 0x8fe4162b  dyld 132.1 (???) <A4F6ADCC-6448-37B4-ED6C-ABB2CD06F448> /usr/lib/dyld