Installing on FreeBSD4.3

Help
Ivan Carey
2001-08-29
2002-09-27
  • Ivan Carey
    Ivan Carey
    2001-08-29

    I get errors when I run make.
    I ran tar xzvf hammehead-2.0.4.tar.gz
    then changed to hammehead-2.1.0
    did ./cofigure
    this ran ok
    then ran make and got the following errors
    "hammer.mk", line 51: Missing dependency operator
    "hammer.mk", line 55: Need an operator
    "hammer.mk", line 56: Missing dependency operator
    "hammer.mk", line 60: Need an operator
    "hammer.mk", line 61: Missing dependency operator
    "hammer.mk", line 64: Need an operator
    "Makdfile", line 34: Missing dependency operator
    "Makefile", line 40: Need an operator
    "Makdfile", line 42: Missing dependency operator
    "Makefile", line 47: Need an operator
    "Makdfile", line 49: Missing dependency operator
    "Makefile", line 53: Need an operator
    make: fatal errors encountered -- cannot continue

    I noticed that line 51 in hammer.mk says
    # assumes 2.2.7
    this is the version of FreeBSD

    Is it a version of FreeBSD problem or could it be that I do not have other required files for make

    Thanks
    Ivan

     
    • Geoff Wong
      Geoff Wong
      2001-08-29

      Hmm - there's still GNU make dependent make stuff in hammerhead's makefiles. I suggest running "gmake" on FreeBSD.

      Currently I don't have access to a FreeBSD installation so I can't test that for sure.

       
      • Ivan Carey
        Ivan Carey
        2001-08-30

        dredd
        Thanks for your reply
        gmake
        Command not found

        Ivan

         
    • Geoff Wong
      Geoff Wong
      2001-08-30

      You'll have to install GNU make (as gmake). I don't think FreeBSD comes with GNU tools installed by default (license issues). Either that or tweak hammer.mk or the Makefile in src/ so they work with FreeBSD's make.

      sorry,
      Geoff

       
    • both of make, gmake doesn't work..
      --;
      I tried in freeBSD 4.6