Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

GyachI V1.2.11 installation

Krish
2011-09-07
2013-04-23
  • Krish
    Krish
    2011-09-07

    I tried installing Gyachi V.1.2.11 on my laptop (Fedora release 14, Linux 2.6.35.14-95.fc14.x86_64 #1 SMP) using following commands,
    ./autogen.sh
    ./configure -enable-maintainer-mode -disable-wine
      make gyachi.spec
      make
      make install

    Following this, I am able to launch Gyachi and join the chat-rooms without any CAPTCHA problem. However, when I try starting webcam, two pop-up windows appear with following error messages
    (a)  Gyachi (Webcam broadcaster):
           An error occured at 'ioctl VIDIOCGCAP'
            Wrong device
    (b)   Gyachi (Webcam broadcaster):
           Fatal: video format not supported by grab device

    The same message appears when I try installing v 1.2.10 using above steps. However, when I install "rpm" package for v 1.2.10 using "yum" from the fedora distribution, the webcam works fine.

    I have following two questions,

    (1) To make the webcam work for v 1.2.11, what missing packages should be installed ? Do I need to enable/disable any configuration option?

    (2) What features require the "wine" support ? Which packages need to be installed to make the "configure" work without disabling the "wine" ?

    (3) Why do we need to use the "-enable-maintainer-mode" in the configuration option ?

    I would appreciate if anyone can help me resolve these issues
    Thanks
    Krish.

     
  • Prabhat Ranjan
    Prabhat Ranjan
    2011-09-07

    I am facing same problem but webcam works, if you run from command line.

     
  • Krish
    Krish
    2011-09-09

    I found that the problem was a missing package. I installed "libv4l-devel" and "libv4l" packages and recompiled Gyachi V.1.2.11 using steps stated in my first post. The webcam now works fine. I found it strange that the compilation did not warn me about this missing package.
    -krish