GXSM crash on startup – fresh install

willpaul
2012-01-27
2012-09-14
  • willpaul
    willpaul
    2012-01-27

    This is to report some observations we had when trying to get 1.27.2 running.
    It kept crashing on startup – several windows would open, perhaps including a
    non-updated Pan View, and then the whole thing would freeze. After fighting
    with this for a while, we tried reverting to the most recent Live DVD, hoping
    to get GXSM running. This also didn’t work.

    We copied the source code tree from James Hedberg's computer (1.24.1) which
    ended up working fine.

    Yesterday, I managed to compile and get 1.27.2 running, but in a weird way.
    One issue about setting it up was that no hardware was selectable from the
    drop-down menu when initially configuring it. The only way we could select SPM
    hardware in the configuration screen was to start “gxsm –d
    /dev/sranger_mk2_0”. But then once GXSM started, it would crash. I finally
    tried starting with no hardware to see if GXSM would actually start, and it
    did. I also rebuilt the gconf with “gxsm -hno --force-rebuild-gconf-defaults”.
    I configured it for no hardware in the configuration panel. GXSM started. Then
    in Settings > Preferences, I was able to select SPM hardware and specify
    /dev/sranger_mk2_0. Upon exiting and restarting , GXSM loaded and seemed
    functional.

    Not sure why this was weird/difficult in the more recent versions but 1.24.1
    worked fine. Anyways, hopefully these observations are of some use.

    Cheers

    Will

     
  • For me it sounds like that your DSP board is not recognized by Linux. To check
    this please run the initSR.py script. It checkes for the device, sets if
    necessary the permissions and so on. Please report the output. If the board
    was found, GXSM should run.

    Just a note about the Linux distribution: This contains an older version of
    GXSM. I did not update it after the NC-AFM conference in Lindau (that`s were
    the name Lindau historic comes from), because I spend some time to make the
    ubuntu packages.

    If you compile GXSM yourself and start from a fresh gconf you indeed are not
    able to select any hardware type in the wizard which comes up the first time
    you start gxsm. Make the adjustements as needed - especially the device
    /dev/sranger_mk2_0. The shut down Gxsm and restart. The go to Preferences
    again and you should be able to select a proper hardware type. Should be
    something with SRangerMK2:SPM or similar. Restart again. Please use in all
    cases the normal startup from the menu!

    A final note: GXSM-1.24.1 and GXSM-1.27.2 require different DSP firmware.
    Please make sure, that you have uploaded a proper one. The device interface
    has changed slightly between these versions. I think for the GXSM-1.24.1 it is
    20.16 and for the lastest 20.24 or so. For the liveDVD you find the proper DSP
    code in ~/SRanger/TiCC-project-files/MK2-A810_FB_spmcontrol/FB_spmcontrol.out
    (assuming you have an OPEN SOURCE SPM CONTROLLER with SR-MK2 & A810).

    Thorsten :-)