Hello,

I am trying to build a small application for overo-air using bitbake, but I got the following error, I don't know what it complains

$ bitbake LP_filter
__builtin__:74: DeprecationWarning: the sets module is deprecated
NOTE: Psyco JIT Compiler (http://psyco.sf.net) not available. Install it to increase performance.
NOTE: Handling BitBake files: - (6950/6950) [100 %]
NOTE: Parsing finished. 6678 cached, 0 parsed, 272 skipped, 2 masked.
NOTE: Cache is clean, not saving.
ERROR: Nothing PROVIDES 'LP_filter'

I refer to the following pages when I setup the env, dir structure, and the bb file. The helloworld example works, but not this one.
http://www.gumstix.net/Software/view/Software-Overo/Setting-up-a-build-environment/111.html
http://www.gumstix.net/Software/view/Build-system-overview/Hello-world-tutorial/111.html

DIR:
/host/overo-oe/user.collection/packages/LP_filter
     files
     LP_filter-1.0.0.bb

and the bb file contains:

DESCRIPTION = "test filter"

PR = "r0"

DEPENDS = ""

SRC_URI = " \
  file://filt.c \
  file://testfilt.c \
  file://filt.h \
  file://Makefile \
"

S = "${WORKDIR}"

do_install () {
    install -d ${D}${bindir}/
    install -m 0755 ${S}/LP_filter ${D}${bindir}/
}

FILES_${PN} = "${bindir}/LP_filter"


can anyone let me know what the error complains about?

Thanks,
Dave