Samuel

Noting sporadic failures when attempting to connect the connex bt400 via Bluetooth serial profile to other devices we tried to lower the HCI UART speed by the line in the /etc/default/Bluetooth file HCIATTACH_SPEED=230400 (by default it is 921600).  Well we did that rebooted and Bluetooth disappeared.  HCITOOL DEV showed no devices.  We went back and set the speed to the original value and still no Bluetooth.  We did the same thing on another gumstix and again we killed (permanently) the Bluetooth capability.  Any ideas? We even reflashed the devices but still no Bluetooth.


There may be a couple of things going on here. The pba313xxx only works at 115k and also I've noticed that the uart has problems on my gumstix that has the pba313xxx.

Craig told me that attempts to change the module speed on pba313xxx would result in bricking the adapter. The adapter permanently jumps to a speed above 921k that gumstix cannot use. So Craig put in some exception code so attempts to change it to 921k were actually ignored and it stayed at 115k. You may have bricked it by trying to use a speed that goes around that exception code and tries to set the speed.

I have noticed bluetooth is a little unreliable on my newer gumstix, and not just built-in bluetooth. I also have an older one with the "rok" bt adapter that can actually reach 921k without problems. I built an external bluetooth module and found that it was strangely also unreliable (would need a reset occasionally) when used with the new gumstix but worked fine on the older board. It's as if the newer board is experiencing noise or something on its uarts. I'm not sure what other explanation there could be.

Brad