hola,

so today i tried tha latest svn code for the buildroot.
i made a new image and loaded the sound modules:

lsmod
snd_pxa2xx_ac97         6124  0
snd_pxa2xx_pcm          4672  1 snd_pxa2xx_ac97
snd_ac97_codec         96536  1 snd_pxa2xx_ac97
ac97_bus                2112  1 snd_ac97_codec
snd_pcm_oss            39200  0
snd_pcm                62976  4 snd_pxa2xx_ac97,snd_pxa2xx_pcm
,snd_ac97_codec,snd_pcm_oss
snd_timer              19612  1 snd_pcm
snd_page_alloc          5960  1 snd_pcm
snd_mixer_oss          14784  1 snd_pcm_oss
snd                    46028  6 snd_pxa2xx_ac97,snd_ac97_codec,snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss
soundcore               6652  1 snd
mcf25                 197824  0
cfio                    5152  1 mcf25
af_packet              16996  0
g_ether                23552  0
pxa2xx_udc             14436  1 g_ether
gumstix_gadget          1440  1 pxa2xx_udc
l2cap                  20128  2
hci_uart                8188  3
bluetooth              49184  6 l2cap,hci_uart
proc_gpio               7128  0
gumstix_bluetooth       1440  1 bluetooth
pxa2xx_cs               3044  1
pxa2xx_core            10456  1 pxa2xx_cs
pcmcia                 25276  1 cfio
pcmcia_core            31432  4 mcf25,cfio,pxa2xx_core,pcmcia
firmware_class          7680  1 pcmcia
smc91x                 16392  0
mii                     4768  1 smc91x
gumstix_smc91x          3040  1 smc91x
unix                   23592  14

but then tried to use the created /dev/dsp got:

# bplay phone.wav
bplay: /dev/dsp: Invalid argument

i also tried brec and it failed with the same error, i've read examples on how to use sound but nothing on troubleshooting, what i have is a connex+gpstix

i have tried with svn code and root.fs images from sourceforge.

the deadline for the porject is approaching and it heavily relays in the use of the soundcard, i dont want to have to let this  platform aside since i hope this has to be a small issue im unable by myself to discover, please help me troubleshooting this.

/a