Hi,

I'm having the same problem when trying to build u-boot-omap3. The error messages I get are identical to those experienced by Graeme Jordan (except for the path detail for my local build directory).

I've cleared all the cached data, and when I run a fresh bitbake, I get the following error:

...
NOTE: Running task 1436 of 3032 (ID: 110, /home/xoxo/overo-oe/org.openembedded.dev/recipes/u-boot/u-boot-omap3_git.bb, do_setscene)
NOTE: Running task 1437 of 3032 (ID: 111, /home/xoxo/overo-oe/org.openembedded.dev/recipes/u-boot/u-boot-omap3_git.bb, do_fetch)
NOTE: fetch http://www.angstrom-distribution.org/unstable/sources/git_git.denx.de.u-boot-ti.git.tar.gz
--2009-09-23 21:53:47--  http://www.angstrom-distribution.org/unstable/sources/git_git.denx.de.u-boot-ti.git.tar.gz
Resolving www.angstrom-distribution.org... 188.40.83.200
Connecting to www.angstrom-distribution.org|188.40.83.200|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2009-09-23 21:53:47 ERROR 404: Not Found.

NOTE: fetch http://mirrors.openembedded.org//git_git.denx.de.u-boot-ti.git.tar.gz
--2009-09-23 21:53:47--  http://mirrors.openembedded.org//git_git.denx.de.u-boot-ti.git.tar.gz
Resolving mirrors.openembedded.org... 82.197.159.157
Connecting to mirrors.openembedded.org|82.197.159.157|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2009-09-23 21:53:48 ERROR 404: Not Found.

NOTE: fetch http://sources.openembedded.org//git_git.denx.de.u-boot-ti.git.tar.gz
--2009-09-23 21:53:48--  http://sources.openembedded.org//git_git.denx.de.u-boot-ti.git.tar.gz
Resolving sources.openembedded.org... 140.211.169.165
Connecting to sources.openembedded.org|140.211.169.165|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2009-09-23 21:53:48 ERROR 404: Not Found.

Initialized empty Git repository in /home/xoxo/overo-oe/sources/git/git.denx.de.u-boot-ti.git/.git/
From git://git.denx.de/u-boot-ti
 * branch            master     -> FETCH_HEAD
NOTE: Creating tarball of git repository
fatal: failed to unpack tree object 8c3c42e7b84169cf1561985c40e8d1de5f300e06
NOTE: Task failed: Fetch failed: Fetch command export HOME=/home/xoxo; export SSH_AUTH_SOCK=/tmp/keyring-WRPIAV/socket.ssh; export PATH=/home/xoxo/overo-oe/tmp/staging/i686-linux/usr/bin/overo-angstrom-linux-gnueabi:/home/xoxo/overo-oe/tmp/staging/i686-linux/usr/bin/armv7a-angstrom-linux-gnueabi:/home/xoxo/overo-oe/tmp/staging/i686-linux/usr/sbin:/home/xoxo/overo-oe/tmp/staging/i686-linux/usr/bin:/home/xoxo/overo-oe/tmp/cross/armv7a/bin:/home/xoxo/overo-oe/tmp/staging/i686-linux/sbin:/home/xoxo/overo-oe/tmp/staging/i686-linux/bin:/home/xoxo/overo-oe/bitbake/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games; git read-tree 8c3c42e7b84169cf1561985c40e8d1de5f300e06 failed with signal 128, output:
fatal: failed to unpack tree object 8c3c42e7b84169cf1561985c40e8d1de5f300e06

ERROR: TaskFailed event exception, aborting
ERROR: Build of /home/xoxo/overo-oe/org.openembedded.dev/recipes/u-boot/u-boot-omap3_git.bb do_fetch failed
ERROR: Task 111 (/home/xoxo/overo-oe/org.openembedded.dev/recipes/u-boot/u-boot-omap3_git.bb, do_fetch) failed
NOTE: Tasks Summary: Attempted 1436 tasks of which 0 didn't need to be rerun and 1 failed.
ERROR: '/home/xoxo/overo-oe/org.openembedded.dev/recipes/u-boot/u-boot-omap3_git.bb' failed


It looks as if it can't find a u-boot related tarball. I've tried to access the three URLs where it looks for the tarball manually and can't find the files where they are referenced that way either.

The other things I've tried so far are as follows:
- building u-boot using bitbake (worked fine)
- clearing entire working directory and starting again
- checking my firewall settings (git and svn traffic should be allowed through; I don't think this is the issue)
- looking for the u-boot-omap3 file and downloading it manually (not sure where to find it)

Any advice or suggestions would be gratefully received as I'm not sure what to do next.

Many thanks,


Graham



On Wed, Sep 23, 2009 at 11:46 PM, Grahame Jordan <gbj@theforce.com.au> wrote:
Hi,

I am building a fresh overo-oe tree and fail on u-boot-omap3.
bitbake u-boot bakes well but not u-boot-omap3.

gjordan@bwing:~/overo-oe$ bitbake u-boot-omap3
NOTE: Handling BitBake files: - (7162/7162) [100 %]
NOTE: Parsing finished. 6883 cached, 0 parsed, 279 skipped, 2 masked.
NOTE: Cache is clean, not saving.
NOTE: Resolving any missing task queue dependencies
NOTE: Preparing runqueue
NOTE: Executing runqueue
NOTE: Running task 409 of 605 (ID: 2,
/home/gjordan/overo-oe/org.openembedded.dev/recipes/u-boot/u-boot-omap3_git.bb,
do_fetch)
 From git://git.denx.de/u-boot-ti
 * branch            master     -> FETCH_HEAD
NOTE: Creating tarball of git repository
fatal: failed to unpack tree object 8c3c42e7b84169cf1561985c40e8d1de5f300e06
NOTE: Task failed: Fetch failed: Fetch command export
HOME=/home/gjordan; export
PATH=/home/gjordan/overo-oe/tmp/staging/i686-linux/usr/bin/overo-angstrom-linux-gnueabi:/home/gjordan/overo-oe/tmp/staging/i686-linux/usr/bin/armv7a-angstrom-linux-gnueabi:/home/gjordan/overo-oe/tmp/staging/i686-linux/usr/sbin:/home/gjordan/overo-oe/tmp/staging/i686-linux/usr/bin:/home/gjordan/overo-oe/tmp/cross/armv7a/bin:/home/gjordan/overo-oe/tmp/staging/i686-linux/sbin:/home/gjordan/overo-oe/tmp/staging/i686-linux/bin:/home/gjordan/overo-oe/bitbake/bin:/home/gjordan/overo-oe/bitbake/bin:/home/gjordan/java/TruFlo/gumstix_verdex/bin:/home/TruFlo-Verdex/bitbake/bin:/home/gjordan/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/NX/bin:/opt/qtjambi/bin:/opt/installjammer:/opt/launch4j;
git read-tree 8c3c42e7b84169cf1561985c40e8d1de5f300e06 failed with
signal 128, output:
fatal: failed to unpack tree object 8c3c42e7b84169cf1561985c40e8d1de5f300e06

ERROR: TaskFailed event exception, aborting
ERROR: Build of
/home/gjordan/overo-oe/org.openembedded.dev/recipes/u-boot/u-boot-omap3_git.bb
do_fetch failed
ERROR: Task 2
(/home/gjordan/overo-oe/org.openembedded.dev/recipes/u-boot/u-boot-omap3_git.bb,
do_fetch) failed
NOTE: Tasks Summary: Attempted 408 tasks of which 408 didn't need to be
rerun and 1 failed.
ERROR:
'/home/gjordan/overo-oe/org.openembedded.dev/recipes/u-boot/u-boot-omap3_git.bb'
failed


Thanks


Grahame Jordan


John Merchant wrote:
> Hi Chris,
>
> Thanks, that did the trick.  Once I built mtd-utils manually, the console
> image built without any further problems.
>
> John
>
>
> Hi John,
>
> It looks like the u-boot recipe is missing a dependency on the
> mtd-utils package. If you run 'bitbake mtd-utils' and then re-run your
> bitbake command to build your image you should be in business.
>
> Chris
>
>


------------------------------------------------------------------------------
Come build with us! The BlackBerry&reg; Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay
ahead of the curve. Join us from November 9&#45;12, 2009. Register now&#33;
http://p.sf.net/sfu/devconf
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users