There was a bug which I fixed in buildroot r1139 which exhibited exactly this symptom.  Which rootfs revision are you using? (cat /etc/gumstix-release to find out).

C

On Nov 1, 2006, at 11:52 AM, raja gopalan wrote:

hi

i tried to get the USBnet conn.(in windows xp) working for (connex+tweener+audiostix) combination. I went as per the steps in Windows XP usbnet. All went fine, the driver was installed. The i bridged my LAN and the USBnet connection(after removing firewall, of course). Then plugged out and plugged in my USB cable(at this time, i got 'unkown usb device' notification in systray, but as the usbnet n/w conn. showed up, i ignored the former), rebooted. After bootup(before login), both my dhcp and usbdev is shown configured.
-------------------------
Starting network...
udhcpc (v0.9.9-pre) started
Dec 31 16:00:27 udhcpc[239]: udhcpc (v0.9.9-pre) started
pxa2xx_udc: version 14-Dec-2003
usb0: Ethernet Gadget, version: Equinox 2004
usb0: using pxa2xx_udc, OUT ep2out-bulk IN ep1in-bulk STATUS ep6in-bulk
usb0: MAC a2:2d:09:74:aa:a1
usb0: HOST MAC a2:2d:09:74:aa:a2
usb0: RNDIS ready
NET: Registered protocol family 17
Starting dropbear sshd: OK
Starting httpd...
Starting Rendezvous: usb0: full speed config #2: 100 mA, Ethernet Gadget, using
RNDIS
---------------------------------------
But i found by ifconfig that an ip address has not yet been allotted yet.
So i tried /etc/init.d/S40network restart to restart the dhcp configuration, and it did, but still no ip address.. :(

This is what i get on ifconfig
--------------------------------------------

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:9 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3099 (3.0 KiB)  TX bytes:3099 (3.0 KiB)

usb0      Link encap:Ethernet  HWaddr A2:2D:09:74:AA:A1
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1312 (1.2 KiB)  TX bytes:12680 (12.3 KiB)
---------------------------------------------

i tried to manually allot an ip-address like ifconfig usb0 192.168.0.2, and tried to ping my system, but failure, again!
--------------------------------
PING 10.114.12.89 (10.114.12.89): 56 data bytes
ping: sendto: Network is unreachable
----------------------------------
pls help me.. what am i doin wrong?

Thanx,
Rajagopalan.


Find out what India is talking about on - Yahoo! Answers India
Send FREE SMS to your friend's mobile from Yahoo! Messenger Version 8. Get it NOW
-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users