Thank you,

I found somewhere that if you append "consoleblank=(some number)" to your bootargs u-boot environment variable, it sets the number of seconds until the screen is blanked, and if you set it to 0, it doesn't blank it at all.  I tested this with various values for the time, and it definitely does make a panel_suspend happen after that much time.  However, even with the option set to 0, it still goes blank.  However, it seems as though it is for a different reason, though.  Before it goes blank, I get a message:

nano-X: client closed socket: 7
Destroy 7 client resources
Destroy window 3 eventclient mask 00200006
Destroy window 3
Destroy gc 1001
Destroy timer 2020
Window list:
2(6),1(0),
Pixmap list:

GC list:
1000(6),
Font list:

Region list:

Image list:

Timer list:
2019(6),

I guess I had assumed that this was a result of the panel_suspend, but maybe it's something not directly related at all.  The fact that it happens soon before the panel_suspend is a bit coincidental, but as we all know, correlation does not imply causation.  So, does anyone have any idea what's causing this problem?

From: Patrick Maheral (DWI - CA/Ottawa) [Patrick.Maheral@dragonwaveinc.com]
Sent: Thursday, December 22, 2011 3:05 PM
To: General mailing list for gumstix users.
Subject: Re: [Gumstix-users] Panel Suspend

Hi Charles,
 
If you can log into the device using the console port, try issuing the following command when the screen shuts off:
 
echo 0 > /sys/class/graphics/fb0/blank
 
That should "unblank" the screen.  If that works, then it is the kernel that is disabling the display.  An ugly way to
prevent this would be to regularly issue the above command.  I think there is a way to tell the kernel not to
blank the screen, but I can't remember how to do that.
 
Patrick


From: McPherson, Charles A [mailto:Charles_McPherson@student.uml.edu]
Sent: December 22, 2011 12:41
To: gumstix-users@lists.sourceforge.net
Subject: [Gumstix-users] Panel Suspend

 Hi Guys,

I'm using an Overo Fire with a Palo35 expansion board and the LG LB035Q02 display that comes with it.  The problem that I'm having is that the panel shuts off every 9 and a half minutes or so and there's no way to get it back on.  My theory is that this happens when the system goes to sleep, but since it shuts off the panel, and that is my only human interface device, there is no way to get it to wake up again without hitting the "reset" button.  Whenever it happens, it executes a function called "panel_suspend()" which is part of the panel driver.  Does anyone have any ideas about how to solve this issue?

Thanks for any help,

Charles McPherson