I know this error occurs if the root filesystem is formatted with ext4. If the file system is ext4, try creating the micro sd card with an ext3 partition instead.

~Tyler Jones


On 6 February 2013 17:16, davidlopez <davidalopez1989@gmail.com> wrote:
Hi all,

I just got my gumstix, along with Tobi and Robovero expansion boards. In
order to get gumstix to work with the Robovero board I needed to update to
the lastest image so I followed the instructions on the How To page for
creating a bootable SD card and then using it for the update. I was able to
successfully follow all the instructions steps smoothly without seeing any
errors along the way up to the final step that is. When I restart the
gumstix without the SD Card I get this error:

Kernel panic - not syncing: VFS: Unable to mount root fs on
unknown-block(0,0)

Not sure what went wrong since I carefully followed all the steps and didn't
encounter any errors along the way. I can still boot from the SD card just
fine, however if I wanted to start over from the first step and recreate the
bootable SD card, it is not listed under /dev so I'm not able reformat. I
also tried restarting the process starting from after the bootable SD card
is made, but still end up with the same error.

Not sure what to look into to fix this so any help would be greatly
appreciated.
Thanks!



--
View this message in context: http://gumstix.8.n6.nabble.com/Updating-to-Lastest-Stable-Image-tp4966740.html
Sent from the Gumstix mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Free Next-Gen Firewall Hardware Offer
Buy your Sophos next-gen firewall before the end March 2013
and get the hardware for free! Learn more.
http://p.sf.net/sfu/sophos-d2d-feb
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users