ok sorry for the late reply. 

Everything works fine with the 3.2 kernel!  The only weird thing is that I cannot access a webcam when plugged into the tobi, but I can when I'm plugged into the robovero.  Doesn't really matter for me though.. I am going to be using the robovero.

I'm not too thrilled with the performance of streaming video from the logitech c290, but I'm assuming thats because I have to convert colorspace.  At 640x420 I still use 99% of the cpu.  at 320x240 is goes down to about 40%.

Andrew, I think I stumbled upon your blog while trying to find a solution (specifically the H.264 RTP Video Streaming post).  I'm going to be looking into that and hopefully I can get similar performance.

Thanks again.
-Jeff

On Fri, Jul 6, 2012 at 8:01 AM, Jeff L <jeffreylaut@gmail.com> wrote:
Hi Andrew,

You were right. 'show-version' returned the same thing you get.  Last night I bitbaked the dsp-console-image with linux-omap3_3.2, and this morning it was finished with no errors.  I probably won't have a chance to test it out until later this afternoon or tonight, but I'll be sure to report back the results.  Hopefully there are no problems.

Thanks!
Jeff


On Thu, Jul 5, 2012 at 3:36 PM, acsmith [via Gumstix] <[hidden email]> wrote:
When I was recompiling the omap3-console-image I had from months ago, it was configured to use 2.6.39 by default.  However, I just redid my build environment following the exact method that you listed in your link and now my default kernel is set to 3.2.  If I run:

bitbake --show-version | grep linux-omap3

I get:

linux-omap3                        0:3.2-r103
linux-omap3-caspapx        0:2.6.34-r103

This was straight out of the box configuration, so it looks like 3.2 is the default kernel now.  I didn't have to change anything.  However, I don't think you need to rebuild your openembedded environment from scratch.  I think you can do something like this from Jumpnowtek - Bottom of page:

Add a line like this to $OVEROTOP/build/conf/local.conf

# prefer 2.6.34 over the default gumstix 2.6.36 kernel
PREFERRED_VERSION_linux-omap3 = "2.6.34"

except you want version 3, so maybe change this to
PREFERRED_VERSION_linux-omap3 = "3.2"

After that you should be able to run

bitbake -c rebuild virtual/kernel

I haven't done this but it makes sense it would work.  It worked for me when I wanted to switch back to kernel 2.6.34 from 2.6.39.  When you're done run
bitbake --show-versions | grep linux-omap3

and post back what comes up, I'd be interested in seeing what turns up.



If you reply to this email, your message will be added to the discussion below:
http://gumstix.8.n6.nabble.com/DSP-robovero-and-3-0-0-tp4964810p4964832.html
To unsubscribe from DSP, robovero, and 3.0.0, click here.
NAML



View this message in context: Re: DSP, robovero, and 3.0.0
Sent from the Gumstix mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users