Hi All.

I am new to the gumstix mail list.  I am designing embedded HW for an audio project, and am planning on using gumstix as part of the early production hardware.

USB Host does not seem to be working on my board.  I do not get any messages at a terminal prompt when devices are plugged.  Nor does 'lsusb' show anything.  Should it 'work' out of the box, or am I doing something wrong?

Here's the setup & background:

I purchased an Overo Earth + Tobi board last week from gumstix.com, and found it had a build image dated from 2009.  This seemed pretty stale, so I created an SD card with the latest build per the directions on the gumstix site.  http://cumulus.gumstix.org/images/angstrom/factory/
The build is dated 2011-08-30, and results in a kernel of 2.6.39.

After the OS was intalled, I began to port our software from our other platform, and have been able to successfully get data to/from the Tobi onboard audio input/outputs.  Our application requires a second audio port.  To accomplish this, I am trying to connect a Behringer UCA202 USB Sound card to the Tobi board.  When I plug the sound card into the USB Host port, nothing happens.  After reading these archives, I find this is not too surprising as the port only communicates with 2.0 devices (and this sound card is 1.1).  So I tried a USB Flash drive, 2.0 unpowered hub, and 2.0 powered hub, as well as combinations of these devices.  Still nothing.  Lsusb always returns this...
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Incidentally, I have tested the UCA202 on a Linux PC, and it works perfectly.

I have read about the R26 on early Overo boards which kept the USB Host from working correctly.  Given that my Overo Earth came with kernel build from 2009, I am concerned that perhaps somehow my order was fulfilled with a really old module that might still contain R26.  Does anyone know where to find this resistor on the board?  I studied the silkscreen pretty carefully, but could not find R26.

I also turned up a few internet threads talking about the 2.6.39rc1 and rc2 having polarity reversed on an (reset/enable?) line for the USB Host PHY.  It appeared from the threads that the problem was well understood and would be fixed in the 2.6.39 release.  Has anyone confirmed USB Host operation with the 2011-08-30 pre-canned build from Gumstix website?

Last, it seems that in general, users have more success interfacing with the OTG port.  I understand that a special cable is needed with ground present on the ID pin to activate host mode on the Overo/Tobi.  Gumstix sells a cable, but it terminates to Mini connectors, which are not the typical hub interface of a Standard A connector.  If anyone is using a hub on the OTG port, could you describe your setup, please?  Did you have to use converter cables to interwork the different connector styles and genders from the hub to the Tobi?

Any other ideas to check?

Thanks much!

Regards,
Nate