Is there any reason you can't use an older version of ubuntu? There are some known issues with ubuntu 11.10 (and possibly also 11.04?), and afaik the "workarounds" that have been posted to the mailing list aren't working for everyone. If you can I'd suggest going with ubuntu 10.04 (an LTS release that should be supported till 2013 I think) or even 10.10. I've had no problems building with either of those distros. 32-bit also seems less problematic many times, but personally I've not experienced any issues with 64-bit ubuntu 10.04 or 10.10.

I'd say that 32-bit ubuntu 10.04 is your best bet as it will be supported for a while by ubuntu and I'm pretty sure this is the version the gumstix devs use, so it probably has the fewest bugs when it comes to the bitbake process.

I know this isn't a "fix" for your current error, but it may be an easier route to go down in the long run.

Chris

On Tue, Dec 20, 2011 at 4:03 PM, FatalError <jim@macrousa.com> wrote:
>What distro are your running on your build machine?

Versions in current use:
Build Configuration:
BB_VERSION        = "1.12.0"
METADATA_BRANCH   = "overo-2011.03"
METADATA_REVISION = "d042ac9"
TARGET_ARCH       = "arm"
TARGET_OS         = "linux-gnueabi"
MACHINE           = "overo"
DISTRO            = "angstrom"
DISTRO_VERSION    = "2011.03"
TARGET_FPU        = "hard"

Using window 7 64-bit
Oracle VM v4.1.6 r74713
Ubuntu 11.10 64-bit



--
View this message in context: http://gumstix.8.n6.nabble.com/openssl-native-compile-error-tp630730p2006743.html
Sent from the Gumstix mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Write once. Port to many.
Get the SDK and tools to simplify cross-platform app development. Create
new or port existing apps to sell to consumers worldwide. Explore the
Intel AppUpSM program developer opportunity. appdeveloper.intel.com/join
http://p.sf.net/sfu/intel-appdev
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users