To write a file to the file system, try this:

$ dd if=/dev/zero of=test.file bs=52428800 count=1

This will create a 50MB file.

Adam

On Wed, May 29, 2013 at 1:59 PM, Florian Vaussard [via Gumstix] <[hidden email]> wrote:


On 05/29/2013 10:06 PM, Qandeel Sajid wrote:
> It's not connected to the internet but I think it should have just
> given me a small error instead of a kernel panic.
>

Indeed, this should not be the root cause, but it can be one trigger.

> Considering what Florian mentioned, I used fsck before I booted into
> it and the results showed that the file system was fine. After the
> kernel panic, the file systems were corrupted and I used fsck to fix
> them. However, when I tried to boot it again after the kernel panic,
> it would either output junk or stop somewhere at the start of the
> autoboot process and I had to reinstall the image.
>

So probably the FS was badly damaged during the battle...

> No, I didn't do anything before the sudo apt-get update. Also, in
> another one of my test runs, the file system error happened
> automatically without me typing in any command. l Adam, are you using
> the image from:
> http://gumstix.org/getting-started-guide/241-get-an-image.html ?
>
> After I download the image I tried to run ros using $ cd ~/ros $ .
> ./setup.sh $ roscore from:
> http://wiki.gumstix.org/index.php?title=ROS A kernel panic occurs
> when I do . ./setup.sh and only outputs /Kernel panic - not syncing:
> Attempted to kill init! exitcode=0x000000/.
>

Could it be triggered when a process tries to write on your SD card, maybe?
The kernel panic in itself only indicates a problem with the init process.
In your previous post, init presumably got a segfault. To test this
hypothesis, could you write something on the SD card ? If the SD card
is mounted as your rootfs, you can just do a

touch /root/foobar

and / or try to write some data in it.

According to the OMAP3 TRM, cards up to 32GB should be supported. But maybe
your card is defected? Could you try another one?

> I'm using a 32GB sd card and the image only 8GB of it. The rest is
> free space. Should the image be resized to fill the whole card? If
> so, how? I tried using just an 8GB card and booting in to it results
> in either junk or no autoboot.
>

As I am not sure on how you create your SD card, I am not completely
confident in answering your first question. As for the 8 GB card, it
should work if the image fits on it. Have you tried a second one? When
you mean no autoboot, what exactly? Do you see the output of the
bootloader? The kernel decompressor? Or really nothing? In this case,
the first partition is probably not created / installed correctly. Could
you provide a link to the instructions you followed?

> I'm pretty new to hardware so it is possible that I'm forgetting to
> initialize something or just doing something silly, but I made sure
> to follow the instruction on the Gumstix website so I'm not sure what
> that something is.
>

Regards,

Florian

------------------------------------------------------------------------------
Introducing AppDynamics Lite, a free troubleshooting tool for Java/.NET
Get 100% visibility into your production application - at no cost.
Code-level diagnostics for performance bottlenecks with <2% overhead
Download for free and get started troubleshooting in minutes.
http://p.sf.net/sfu/appdyn_d2d_ap1
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users



If you reply to this email, your message will be added to the discussion below:
http://gumstix.8.x6.nabble.com/Pre-built-Linaro-with-ROS-image-runs-into-a-kernel-panic-tp4967307p4967324.html
To start a new topic under Gumstix, email [hidden email]
To unsubscribe from Gumstix, click here.
NAML



View this message in context: Re: Pre-built Linaro with ROS image runs into a kernel panic
Sent from the Gumstix mailing list archive at Nabble.com.