Hello Jeremy, we've been making some changes to the package repo. 
At the moment, most of the Overo packages are in the repository. I will be updating it for Duovero soon (as soon as my current build finishes).
And starting from Yocto 1.4 (Dylan), Smart has replaced Zypper. Please take a look at Smart configuration in our meta layer - https://github.com/gumstix/meta-gumstix-extras/blob/dylan/recipes-images/gumstix/gumstix-console-image.bb
Please keep in mind the Dylan branch is still in beta and feedbacks are most appreciated :)

Adam

On Sun, Aug 11, 2013 at 12:06 PM, jzawodn [via Gumstix] <[hidden email]> wrote:
I had a DuoVero and Parlor board arrive recently.  And after figuring out that it's not really dead:


I've got it up and running using the images that Ash provided.  However, it seems that unlike any of the docs I can find on gumstix.org, there is no opkg or ipkg package manager.  However, it seems that zypper is present and has two repos configured in /etc/zypp/repos.d:

root@duovero:/etc/zypp/repos.d# cat angstrom.repo 
[sakoman]
name=Angstrom
enabled=1
autorefresh=1
type=rpm-md
keeppackages=0
gpgcheck=0

root@duovero:/etc/zypp/repos.d# cat gumstix.repo 
[gumstix]
name=gumstix
enabled=1
autorefresh=1
type=rpm-md
keeppackages=0

But, neither of them seems to exist anymore.

Watch this:

---snip---

root@duovero:~# zypper update
Retrieving repository 'gumstix' metadata [\]
File '/repodata/repomd.xml' not found on medium 'http://package-cache.gumstix.org/'

Abort, retry, ignore? [a/r/i/?] (a): i
Retrieving repository 'gumstix' metadata [error]
Repository 'gumstix' is invalid.
Can't provide /repodata/repomd.xml
Please check if the URIs defined for this repository are pointing to a valid repository.
Warning: Disabling repository 'gumstix' because of the above error.
Retrieving repository 'Angstrom' metadata [\]
File '/repodata/repomd.xml' not found on medium 'http://feeds.angstrom-distribution.org/feeds/core/rpm'

Abort, retry, ignore? [a/r/i/?] (a): i
Retrieving repository 'Angstrom' metadata [error]
Repository 'Angstrom' is invalid.
Can't provide /repodata/repomd.xml
Please check if the URIs defined for this repository are pointing to a valid repository.
Warning: Disabling repository 'Angstrom' because of the above error.
Loading repository data...
Reading installed packages...

Nothing to do.

---snip---

I'm guessing this is a simple oversight, but I've not been able to find references to current repos.

Anyone know?

Thanks,

Jeremy

------------------------------------------------------------------------------
Get 100% visibility into Java/.NET code with AppDynamics Lite!
It's a free troubleshooting tool designed for production.
Get down to code-level detail for bottlenecks, with <2% overhead.
Download for free and get started troubleshooting in minutes.
http://pubads.g.doubleclick.net/gampad/clk?id=48897031&iu=/4140/ostg.clktrk
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users



If you reply to this email, your message will be added to the discussion below:
http://gumstix.8.x6.nabble.com/Proper-location-of-package-repos-for-recent-builds-tp4967696.html
To start a new topic under Gumstix, email [hidden email]
To unsubscribe from Gumstix, click here.
NAML



View this message in context: Re: Proper location of package repos for recent builds?
Sent from the Gumstix mailing list archive at Nabble.com.