Strange.. can you run md5sum on the files you downloaded and check against the hash in README file? 
If that looks good, try running the linaro-media-create tool in sudo.

Let us know!


On Fri, Aug 3, 2012 at 8:06 AM, kris duff <> wrote:
while trying to  :

linaro-media-create --rootfs ext3 --mmc /dev/sdd --dev overo --hwpack Gumstix-Overo-Linaro/Gumstix-Overo-Linaro-armhf-HWPack.tar.gz --binary Gumstix-Overo-Linaro/Gumstix-Overo-Linaro-Precise-ALIP-armhf-RootFS.tar.gz
Are you 100% sure, on selecting [/dev/sdd] (y/n)? y
mv: cannot stat `/tmp/tmp2X3Aem/binary/etc/resolv.conf': No such file or directory
Traceback (most recent call last):
  File "/usr/bin/linaro-media-create", line 122, in <module>
    install_hwpacks(ROOTFS_DIR, TMP_DIR, args.hwpack_force_yes, *hwpacks)
  File "/usr/lib/pymodules/python2.7/linaro_media_create/", line 35, in install_hwpacks
    temporarily_overwrite_file_on_dir('/etc/resolv.conf', chroot_etc, tmp_dir)
  File "/usr/lib/pymodules/python2.7/linaro_media_create/", line 121, in temporarily_overwrite_file_on_dir
  File "/usr/lib/pymodules/python2.7/linaro_media_create/", line 65, in wait
    raise SubcommandNonZeroReturnValue(self._my_args, returncode)
linaro_media_create.cmd_runner.SubcommandNonZeroReturnValue: Sub process "['sudo', 'mv', '-f', '/tmp/tmp2X3Aem/binary/etc/resolv.conf', '/tmp/tmp2X3Aem/resolv.conf']" returned a non-zero value: 1

anybody knows any solution ?



From: Adam Lee <>
To: kris duff <>; General mailing list for gumstix users. <>
Sent: Friday, August 3, 2012 10:14:23 AM
Subject: Re: [Gumstix-users] current stable version for and bitbake ?

Hi Kris,
Unless you absolutely need to use the OE/Yocto framework, you can give the new Linaro image a shot -

It comes with the kernel 3.2 with the LXDE desktop  environment.



On Fri, Aug 3, 2012 at 4:52 AM, kris duff <> wrote:

I want to install all the components to compile software for the gumstix on my computer.

Somewhere on gumstix's website, it tells us to use the branch origin/overo for the files and somewhere else it tells to checkout

Then, I tried the latest bitbake (1.15.3) which complain on a few lines of bitbake.conf and other scripts
so I tried 1.15.2 and 1.15.1 and 1.14 (complain on l = s.split() ) and for both branch I'm having differents errors...

with 1.12 it works but I'm scared it is old and outdated ...

So what is the best match to be nearly up to date ?

Currently trying to compile imap3-console-image with the origin/overo-2011.03 and bitbake 1.12 ...

we'll see how it works ... (bitbake gcc was successfull, see for omap3-console-image, working 1910 of 5154 tasks)

Thank you


Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
gumstix-users mailing list